SMTP Error: Could not connect to SMTP host.

I am having loads of trouble trying to get CS Cart to send emails.



If I use the SMTP setting I get the error in the title:



SMTP host: mail.uk2.net

SMTP username: main email address

SMTP password: xxxxxxxxx

Use SMTP authentication: no



These setting work in outlook



If I use the php mail I seems to work but no emails are sent



Any ideas as I’m sure the emails used to work.



[url]http://www.refinedav.co.uk/quote-request.html[/url]

This is an old post but very applicable to my issue, Could Moderator pls move it to the

“Version 2.x > Issues & Troubleshooting” Forum where it may get seen?

Almost every smtp server will want authentication. Otherwise they are considered an open-relay and will be blacklisted immediately.

The user/password comes from your smtp host (or your smtp configuration if you are running a dedicated server). You need to work with whomever supports your smtp server so they can identify what errors are being generated by requests from your IP address.

That makes perfect sense, but how does mail client connect to the SMTP server without the client knowing what the outgoing server Port address is. For example, In my case:

Outgoing Mail Server: mail.blahblah.com.au (server requires authentication) port 2626

Outgoing Mail Server: (SSL) mail.blahblah.com.au (server requires authentication) port 465

I guess the cscart SMTP function must automatically get the port settings from the server.



Im no expert clearly, but given that the PHP mail function is problematic with spam filters, i need to get SMTP service working.



Interesting to note that the SMTP mail function works perfectly on my MAMP localhost dev machine, but on the live server I get: [quote]SMTP Error: Could not connect to SMTP host.

[/quote]

So I think I have a problem with my hosting.

Yes, cs-cart assumes standard ports (not valid in today's security world).

You might try specifying the port with colon syntax like smtp.foo.bar:2626



Standard ports for smtp are 587 and 25.

25 is rarely used anymore since it got so abused by spammers. But not sure how using a different port (and publishing it like 587) actually helps the initial problem…

The SMTP mail function started working, coinciding with my steps to fix other Outgoing emails sent from (Thunderbird) email client.

My service provider suggested configuring “Email Authentication” enabling “DomainKeys” and setting up domains and IP addresses for “SPF” on my server.

This helps prevent outgoing emails from being tagged as spam by the recipient servers, but I have no idea how/why it seems to have fixed the cs-Cart SMTP mail function that just would not work at all.



However, I think the above is just a coincidence, as the SMTP mail function gave errors again today.

So I have set port with colon syntax like mail.blahblah.com.au:2626 which immediately had the SMTP working again. lets hope its not just a coincidence and keeps working.

For people who are still facing the problem the following config worked for me:



method for sending email: Via SMTP Server

SMTP Host: localhost

the rest as you know (username with '@yourcompany.com' and password)

SMTP authentication: off



I didn't keep SMTP authentication on, as my service provider told me that all SMTP actions on their servers are already authenticated.



But a fact to be noted even though the software sends emails through SMTP, the emails land in the spam or junk folder of th receipient.



Don't no if there is any othe solution than asking customers to check spam or junk and marking email safe!

Thanks! Works perfectly!


[quote name='percy' timestamp='1334430944' post='134836']

For people who are still facing the problem the following config worked for me:



method for sending email: Via SMTP Server

SMTP Host: localhost

the rest as you know (username with '@yourcompany.com' and password)

SMTP authentication: off



I didn't keep SMTP authentication on, as my service provider told me that all SMTP actions on their servers are already authenticated.



But a fact to be noted even though the software sends emails through SMTP, the emails land in the spam or junk folder of th receipient.



Don't no if there is any othe solution than asking customers to check spam or junk and marking email safe!

[/quote]

Hello everyone!



Yesterday we faced the same problem: after pushing the checkout button at the top of the page the string SMTP Error: Could not connect to SMTP host appeared.



Hosting recommended to change the method of sending from “By smtp server” to “By PHP mail function”. All over configuration we left the same and everything start working.



SMTP host: smtp.gmail.com:465

SMTP username: info@labooks.ru

SMTP password: xxxxxxxxx

Use SMTP authentication: yes

Hi, Every one, I'm also facing this problem.

I want to use this function to noticfy cutomer order status changed. But I tried a lot of accounts, it doesn't work.

I had chose Via SMTP Server.

For Php mail, it's work, but I don't want to use this, cause for it will be easily treat as Spam email. And also, my test email service notice me the emails send from this method will be security problems.

Anyone can help??

What version?

SMTP works fine if you set it up correctly and the SMTP server you are sending to is setup to accept connections from you. Ensure you are using 'authentication' since most SMTP hosts will not accept open relay requests.

[quote name='tbirnseth' timestamp='1377281646' post='167282']

What version?

SMTP works fine if you set it up correctly and the SMTP server you are sending to is setup to accept connections from you. Ensure you are using 'authentication' since most SMTP hosts will not accept open relay requests.

[/quote]

Hi, @tbirnseth,

My site version is new version download from CS Cart website last week. CS-Cart Ultimate.

Here are my settings and the results.























I had tried as my Gmail, setting as my email clients.

But this always said failed.

Can you help me?

Thanks for your help.
















Hi, @tbirnseth,
My site version is new version download from CS Cart website last week. CS-Cart Ultimate.
Here are my settings and the results. Please see the screen shots for my sit.
http://s.yunio.com/goK_dg

I had tried as my Gmail, setting as my email clients.
But this always said failed.
Can you help me?
Thanks for your help.


[quote name='joeleu' timestamp='1377308235' post='167291']
[/quote]

joeleu - No idea what you're trying to tell me sending a bunch of urls related to 'swf' files. I don't understand the releationship between your flash files and SMTP. You will have to verify that your smtp credentials do in fact work with whomever hosts your smtp services and that your site is allowed to relay mail using those credentials.

[color=#282828][font=arial, verdana, tahoma, sans-serif]Hi, @tbirnseth,[/font][/color]

[color=#282828][font=arial, verdana, tahoma, sans-serif]Sorry for my mistake posting. [/font][/color]

Here is what I'm want to say:

------------------------------------------------------------------------------------------------------------------

[color=#282828][font=arial, verdana, tahoma, sans-serif]My site version is new version download from CS Cart website last week. CS-Cart Ultimate 4.0.1. [/font][/color]

[color=#282828][font=arial, verdana, tahoma, sans-serif]Here are my settings and the results. Please see the screen shots for my sit. [/font][/color]

[url=“http://s.yunio.com/goK_dg”]http://s.yunio.com/goK_dg[/url][color=#282828][font=arial, verdana, tahoma, sans-serif] [/font][/color]



[color=#282828][font=arial, verdana, tahoma, sans-serif]I had tried as my Gmail, setting as my email clients. [/font][/color]

[color=#282828][font=arial, verdana, tahoma, sans-serif]But this always said failed. [/font][/color]

[color=#282828][font=arial, verdana, tahoma, sans-serif]Can you help me?[/font][/color]

[color=#282828][font=arial, verdana, tahoma, sans-serif]Thanks for your help.[/font][/color]

---------------------------------------------------------------------------------------------------------------------


[quote name='tbirnseth' timestamp='1378155531' post='167690']

joeleu - No idea what you're trying to tell me sending a bunch of urls related to 'swf' files. I don't understand the releationship between your flash files and SMTP. You will have to verify that your smtp credentials do in fact work with whomever hosts your smtp services and that your site is allowed to relay mail using those credentials.

[/quote]

The last jpg that shows the errors pretty clearly indicates that the problem is that it can't connect to your smtp host.

That could be incorrect UR or bad user/pass. Or it could be that your smtp provider only allows specific IP addresses to connect.



Again, this is an issue with the SMTP provider and not with cs-cart.

I also had problems with sending emails, both via PHP mail and SMTP.

I made a “Contact Us” form with Form Builder, and set it to send the email to my Yahoo address, but it was Not sending any email…

My solution was this:



a) Quick Fix (for php mail function)

-in CS-Cart: admin > Settings: Company > scroll down to “Help/Support department e-mail address:”;

-I typed in an email address on my-domain, for eg: contact@my-domain.com or info@my-domain.com* etc.

(initially, all departments had the same Yahoo email address typed in)

*At first, I tested with a fictive email - fictive@my-domain.com - and worked. **Of course, "my-domain.com" was my REAL DOMAIN!




[quote]

([color=#000000]The latest authentication test that Yahoo has incorporated, DMARC, performs the following checks:[/color][list]

[]“From” address should map to the same signing domain

[
]Mail from a domain should match the domain in the “From” header

[/list]

For details, see http://postmaster.ya…tmaster-28.html)

[/quote]





b)Complete Fix (for SMTP server)

-in cPanel > Email Accounts I created the email I wanted, for eg info@my-domain.com

(and added a Forwarder to my Yahoo Email - optional)

-in CS-Cart: admin > Settings: E-mail, I put these values*:

[indent=1]SMTP host: mail.my-domain.com:26 (Outgoing Server & port)[/indent]

[indent=1]SMTP username: info@my-domain.com (the email account)[/indent]

[indent=1]SMTP password: *** (Use the email account's password)[/indent]

[indent=1]Use SMTP authentication: “yes”[/indent]

*taken from cPanel > Email Accounts > Configure Email Client



I hope this will help someone. If anythnig wrong or unclear, please notify me. Thank you!

For people who are still facing the problem the following config worked for me:

method for sending email: Via SMTP Server
SMTP Host: localhost
the rest as you know (username with '@yourcompany.com' and password)
SMTP authentication: off

I didn't keep SMTP authentication on, as my service provider told me that all SMTP actions on their servers are already authenticated.

But a fact to be noted even though the software sends emails through SMTP, the emails land in the spam or junk folder of th receipient.

Don't no if there is any othe solution than asking customers to check spam or junk and marking email safe!

Works perfectly! Thank you