Blog & News Pages Give 404 Error

Hi Guys,

Since the upgrade to 4.3.1 we have had some issues with things not working properly any more (that worked fine in 4.2.4)

We are working through the issues one by one and have a problem that we can’t seem to find any solution for.

The issue is twofold.

Issue 1)

We noticed any page that needs forms (ie contact us) won’t show up. What we mean by that, is we can go to out contact us page under WEBSITE/CONTENT and go to our contact-us page.

We can edit it, Make it Active or Hidden and save it as per normal. But when we go to PREVIEW it, it comes up with a 404 error. When we try to click it on the frontend, its the same deal and we get a 404 error even though the URL pointing to it should be correct.

So under the WEBSITE/CONTENT pages everything else works normally and we can view them fine except the content that uses FORMS.

Issue 2)

Any existing news posts (now converted to blog posts) have similar issues as the above (these don’t use any forms at all though)

When we enable the blog on the front page, it SHOWS the news(blog) articles, but when you click them to read, they give you a 404 error.

The pages are ACTIVE, and are visible as topics, and the SEO URL’s are correct for them, but not a single one is readable via the frontend, or backend preview function without a 404 error.

When we go into the blog pages in the backend, again, we can edit them, change things and save them, but when we go to preview (same as issue 1), it comes up with a 404 error.

We are running 4.3.1, PHP 5.6 on a private server. We think these issues are related, but we don’t know what may be causing them. Any advice or help will be much appreciated.

We have lodged tickets with CS_Cart, but their support is likely taxed at the moment with all the people having issues with 4.3.1 and so, I really don’t expect any sort of timely response from them.

Thanks guys!

It is required to examine the issue directly on your server. If you provide us with the temporary FTP access, our specialists can check the issue

The issue was caused by the bug in version 4.3.1. We have fixed it.


please post the fix here or in relative ticket

best regards,

WSA team

Hey guys,

just an update to this post!

Ecom Labs managed to find and fix the problem in 4.3.1 which is an actual bug in the cart itself.

Funnily enough, Cs-Cart also sent us an email saying that they had also fixed the problem and that it was caused by an old addon we had installed.

Of course, CS-Cart charged me for the fix because after they had disabled the addon, everything worked properly again, but what they didn't realise was that Ecom actually applied the REAL fix at the same time they disabled the addon!

So CS-Cart thought they were the one to fix the cart and charged me accordingly! Edit: to their credit, they did refund the credits once we actually told them the reason it started working again.

Great service as usual from CS-Cart who will by the look of it tell you anything to deduct credits for bugs in their own code!

But, really great fix from Ecom labs who discovered and fixed the real cause of the bug. Well done guys, I can't credit you guys highly enough!

[quote][indent]Now with the 4.3.1 store active, we have the following errors on our site:

  1. when deleting a topic from the website/content pages we get a service unavai lable error
  2. Pages from website/content/ that use forms will not load in a preview window or from the front end and give a 404 error
  3. the links for blog posts on the front end return a 404 error, any new page made under the blog page result in a 404 error when either previewing or trying to access from a URL[/indent]

    Thank you for the request.

    We have examined this issue and found out that all of the mentioned issues are related to the Canonical URL 2.4 add-on. We have disabled it and the issues are gone. Please check it.

    Please let us note that we cannot guarantee the stable operation of third-party themes/modifications/add-ons after upgrade process. Please contact the developers of the add-on regarding this.

    Thank you.


Thank you, bytraper

[quote name='Damir (WSA-team)' timestamp='1432227895' post='215292']

please post the fix here or in relative ticket


I am still not sure that the mentioned issue is on 4.3.1

Same issue - bloq gives 404 error page and does now work even though its there to see in admin. Bloq seems to have taken the previous "news" section. We need a solution on this! Now.

Please PM me temporary FTP access and URL to 404 page