Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

Variant Images Selected Glitch Rate Topic   - - - - -

 
  • leeshields
  • Member
  • Members
  • Join Date: 09-Nov 10
  • 69 posts

Posted 25 October 2018 - 04:06 PM #1

Hi All

 

I have an issue with product variant images, when a variant is selected multiple images are highlighted and marked as selected 

I've attached an image and here is a link to the issue

https://www.garageik...15-length-3.5m/

 

I assume its a javascript glitch, the images selected have the same 1st number for the identifier.

So when "det_img_variant_image_63_1_2" is selected 

"det_img_variant_image_63_1_200" and "det_img_variant_image_63_1_201" are also set as 'selected'

Same happens with number 1 also highlighting '196' and '197'.

 

 

Visual effect
ikon variant glitch.png

 

Switch in source code

ikon variant glitch 2.png

 

 

Any suggestions ??

 

Thanks

 

 

Lee



 
  • eComLabs
  • CS-Cart Expert
  • Authorized Reseller
  • Join Date: 27-Jan 14
  • 19847 posts

Posted 26 October 2018 - 05:06 AM #2

Have you fixed the issue? I failed to reproduce it in Chrome


GET A FREE QUOTE | CS-Cart Add-ons | CS-Cart Licenses | CS-Cart Development | CS-Cart Design | Server Configuration | UniTheme and YOUPI
CS-Cart                USD 345     Multi-Vendor              USD 1250    CS-Cart RU                         24500 руб.
CS-Cart Ultimate  USD 775     CS-Cart + YOUPI      USD 545      CS-Cart RU + UniTheme    36000 руб.


 
  • leeshields
  • Member
  • Members
  • Join Date: 09-Nov 10
  • 69 posts

Posted 26 October 2018 - 01:28 PM #3

Hi, no it isn't fixed

 

The highlight is barely visible (as it doesn't work properly!), just tested in in Chrome and the same result as firefox.

 

 

Lee



 
  • eComLabs
  • CS-Cart Expert
  • Authorized Reseller
  • Join Date: 27-Jan 14
  • 19847 posts

Posted 26 October 2018 - 02:06 PM #4

it is displayed for me in the following way

 

http://prntscr.com/laryw2

 

Try to clear browser cache


GET A FREE QUOTE | CS-Cart Add-ons | CS-Cart Licenses | CS-Cart Development | CS-Cart Design | Server Configuration | UniTheme and YOUPI
CS-Cart                USD 345     Multi-Vendor              USD 1250    CS-Cart RU                         24500 руб.
CS-Cart Ultimate  USD 775     CS-Cart + YOUPI      USD 545      CS-Cart RU + UniTheme    36000 руб.


 
  • leeshields
  • Member
  • Members
  • Join Date: 09-Nov 10
  • 69 posts

Posted 26 October 2018 - 02:17 PM #5

Hi, if you look at it closely the light grey and the marine blue are also highlighted in your screen shot, thats the issue I'm having with it?

 

The CSS on it is deliberately soft to not highlight the issue to clients, this is a live site

 

If you click Blue it then also highlights anthracite and deep red, click between the two red and blue and you will see it appearing on the other blocks

 

Thanks

 

Lee



 
  • eComLabs
  • CS-Cart Expert
  • Authorized Reseller
  • Join Date: 27-Jan 14
  • 19847 posts

Posted 29 October 2018 - 05:45 AM #6

I see the issue now. It is required to examine it on your server


GET A FREE QUOTE | CS-Cart Add-ons | CS-Cart Licenses | CS-Cart Development | CS-Cart Design | Server Configuration | UniTheme and YOUPI
CS-Cart                USD 345     Multi-Vendor              USD 1250    CS-Cart RU                         24500 руб.
CS-Cart Ultimate  USD 775     CS-Cart + YOUPI      USD 545      CS-Cart RU + UniTheme    36000 руб.


 
  • leeshields
  • Member
  • Members
  • Join Date: 09-Nov 10
  • 69 posts

Posted 29 October 2018 - 11:39 AM #7

Hi

 

I've resolved this but the bug isn't fixed. I'm pretty certain it's due to the ID on the first couple of variants being 1 and 2, then picking up others starting 1 or 2 (197, 198 201, 200 etc)

So to get round it I've deleted the variants and added them back in, which of course has changed the ID's, so now they are say 208, 209...

 

I expect if you added lots of variants and eventually got to 2090 then the problem might occur again, but it's an unlikely scenario and not an issue for me.

 

Thanks

Lee