Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

Yet Another Crash Of Site Just By Changing The Font Rate Topic   - - - - -

 
  • dan4288
  • Member
  • Trial users
  • Join Date: 15-Mar 13
  • 47 posts

Posted 17 January 2014 - 02:33 PM #1

Just making a simple change in the theme editor. Changing a font. Then save and bam site is down on front end.
Now i have to go read forums to try and find out where I have to correvt the css because cscart made it so simple with the css now.


Fatal error: Uncaught exception 'Exception' with message 'parse error: failed at `<!DOCTYPE html><html lang=en><head><meta charset=utf-8><title>Error 400 (Font family not found)!!1</title><link href="//fonts.googleapis.com/css?family=Open+Sans:300,400" rel="stylesheet"

Unreal

 
  • NairdaCart
  • Senior Member
  • Members
  • Join Date: 18-Jul 11
  • 306 posts

Posted 17 January 2014 - 03:48 PM #2

Presumably it worked ok when you changed it in your development/testing environment? What's different about your production environment?

 
  • dan4288
  • Member
  • Trial users
  • Join Date: 15-Mar 13
  • 47 posts

Posted 17 January 2014 - 04:24 PM #3

I have it live. All I did was change the font in theme editor and hit save. Then bam error. They need to change the way css erors behave. Having a css error taje down your frontend is bad development.

To note : If you make a css error in custom css it also will take down the site. Everyone makes mistakes and having the site crash is not a great selling feature.