Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

"Facebook" add-on is available for testing. Rate Topic   * * * * * 1 votes

 
  • caHek
  • Architect
  • CS-Cart Architects
  • Join Date: 18-Sep 09
  • 35 posts

Posted 30 March 2011 - 01:04 PM #21

actually, it's still not quite working how it should I still get this on some products, the cache has been cleared etc etc. I have worked out that this will occur when another block is active which we have at the bottom of the page which has an also_bought filing block active on the same page. When the also bought block is disabled or removed then the second "like" button dissapears.


I have resolved this problem. You can download the add-on with changes by the following link: http://cahek.dev.cs-....ction=facebook

wonderful, all is well now thank you. Is there any chance of a like box to sit on the homepage for the default url?


I have 2 issues:

- The product image does not show in FB when you enter a comment.

- I can't use both the like button and the comments tab. It looks like it's either or... How can I do to have both the Like button show next to the image and a Comment tab in the Products tabs?

Thanks for the great mod!


I am investigating the possibility of adding this functionality at the moment. I will contact you with the results in the nearest time.

Kutuzov Alexandr,
CS-Cart Architect Team
Suggest and vote for new features | Report a bug


 
  • Flow
  • Super Duper and Amazingly Sexy Senior
  • Members
  • Join Date: 13-Oct 10
  • 2315 posts

Posted 30 March 2011 - 08:29 PM #22

Works well, thanks!

Just one little question... can you make it an option so it doesn't show faces of people already liking a product? It makes it kinda messy I think,

When life hands you lemons, bring on the Tequila baby!


 
  • jhagg
  • Senior Member
  • Members
  • Join Date: 27-Mar 11
  • 233 posts

Posted 15 April 2011 - 08:19 PM #23

This is working well, i believe I have found a bug if you can be so kind to correct it?

When you use "required products" on a product. Click on the required product tab and "be the first of your friends to like this" shows up twice in that tab....probably best to remove it altogether if possible in that tab or at least remove one instance?

Can you help with this?

 
  • gugga7
  • Senior Member
  • Members
  • Join Date: 16-Mar 08
  • 277 posts

Posted 15 April 2011 - 10:42 PM #24

Too bad this mod is not working right. If a facebook user adds a comment for Product A, it shows up on all other products... Are you getting this as well?

 
  • jhagg
  • Senior Member
  • Members
  • Join Date: 27-Mar 11
  • 233 posts

Posted 15 April 2011 - 10:56 PM #25

Too bad this mod is not working right. If a facebook user adds a comment for Product A, it shows up on all other products... Are you getting this as well?


My site isn't quite live yet so have not discovered this but unfortunate indeed.

Can we get a quick fix on these? Very useful add-on if so....

 
  • gugga7
  • Senior Member
  • Members
  • Join Date: 16-Mar 08
  • 277 posts

Posted 16 April 2011 - 07:18 PM #26

Anyone experiencing this issue?

 
  • mmichaelbiz
  • Junior Member
  • Members
  • Join Date: 17-Apr 11
  • 14 posts

Posted 17 April 2011 - 11:25 AM #27

Uploaded, installed, entered API Key.... worked! (CS-Cart MV)

Excellent addition to CS-Cart - Facebook marketing has never been easier.

Excellent work and thank you.

 
  • mmichaelbiz
  • Junior Member
  • Members
  • Join Date: 17-Apr 11
  • 14 posts

Posted 17 April 2011 - 11:27 AM #28

Uploaded, installed, entered API Key.... worked! (CS-Cart MV)

Absolutely fantastic addon to CS-Cart - Facebook marketing made easy.

Excellent work and thank you.

 
  • mmichaelbiz
  • Junior Member
  • Members
  • Join Date: 17-Apr 11
  • 14 posts

Posted 17 April 2011 - 11:30 AM #29

Too bad this mod is not working right. If a facebook user adds a comment for Product A, it shows up on all other products... Are you getting this as well?


Ah just noticed the same issue - works great except the comments are duplicated accross all products.

Will get very messy eventually... fix required please - hopefully a small tweak.

 
  • mmichaelbiz
  • Junior Member
  • Members
  • Join Date: 17-Apr 11
  • 14 posts

Posted 17 April 2011 - 12:55 PM #30

Product image selected to be displayed in FB is not consistant - Sometimes it selects the correct image sometimes not.

For example I enabled the: Use "Value changer" for the Quantity field option and the Facebook like link showed the Up arrow image from the Value Changer.

Image consisancy fix required.

 
  • mmichaelbiz
  • Junior Member
  • Members
  • Join Date: 17-Apr 11
  • 14 posts

Posted 17 April 2011 - 04:33 PM #31

Also noticed that XHTML 1.0 Validation errors are given with the Facebook plugin:

3 Errors
1 Information Comment


Error:

Line 129, Column 42: document type does not allow element "div" here; assuming missing "object" start-tag
<div id="fb-root" style="display: none;">facebook_content</div>



Error:

Line 132, Column 8: required attribute "type" not specified
<script>

The attribute given above is required for an element that you've used, but you have omitted it. For instance, in most HTML and XHTML document types the "type" attribute is required on the "script" element and the "alt" attribute is required for the "img" element.

Typical values for type are type="text/css" for <style> and type="text/javascript" for <script>.



Error:

Line 161, Column 7: end tag for "object" omitted, but OMITTAG NO was specified
</head>

You may have neglected to close an element, or perhaps you meant to "self-close" an element, that is, ending it with "/>" instead of ">".


Comment:

Line 129, Column 2: start tag was here
<div id="fb-root" style="display: none;">facebook_content</div>

 
  • caHek
  • Architect
  • CS-Cart Architects
  • Join Date: 18-Sep 09
  • 35 posts

Posted 18 April 2011 - 12:20 PM #32

wonderful, all is well now thank you. Is there any chance of a like box to sit on the homepage for the default url?


I added a new block type called 'Facebook like box'. Now you will be able to place the like box where necessary.

actually, it's still not quite working how it should I still get this on some products, the cache has been cleared etc etc. I have worked out that this will occur when another block is active which we have at the bottom of the page which has an also_bought filing block active on the same page. When the also bought block is disabled or removed then the second "like" button dissapears.


It was fixed.

I have 2 issues:

- The product image does not show in FB when you enter a comment.

- I can't use both the like button and the comments tab. It looks like it's either or... How can I do to have both the Like button show next to the image and a Comment tab in the Products tabs?

Thanks for the great mod!


I added one more type of the "Like it" button. Now, if the 'Button + Comments' type is selected, the "Like it" button and the block with comments will be displayed simultaneously.

Works well, thanks!

Just one little question... can you make it an option so it doesn't show faces of people already liking a product? It makes it kinda messy I think,


I removed displaying of peoples' faces already liking a product.

This is working well, i believe I have found a bug if you can be so kind to correct it?

When you use "required products" on a product. Click on the required product tab and "be the first of your friends to like this" shows up twice in that tab....probably best to remove it altogether if possible in that tab or at least remove one instance?

Can you help with this?


It was fixed.

Too bad this mod is not working right. If a facebook user adds a comment for Product A, it shows up on all other products... Are you getting this as well?


It was fixed.

Product image selected to be displayed in FB is not consistant - Sometimes it selects the correct image sometimes not.

For example I enabled the: Use "Value changer" for the Quantity field option and the Facebook like link showed the Up arrow image from the Value Changer.

Image consisancy fix required.


I am looking for the ways how to resolve this problem.

Also noticed that XHTML 1.0 Validation errors are given with the Facebook plugin:

3 Errors
1 Information Comment


Error:

Line 129, Column 42: document type does not allow element "div" here; assuming missing "object" start-tag
<div id="fb-root" style="display: none;">facebook_content</div>



Error:

Line 132, Column 8: required attribute "type" not specified
<script>

The attribute given above is required for an element that you've used, but you have omitted it. For instance, in most HTML and XHTML document types the "type" attribute is required on the "script" element and the "alt" attribute is required for the "img" element.

Typical values for type are type="text/css" for <style> and type="text/javascript" for <script>.



Error:

Line 161, Column 7: end tag for "object" omitted, but OMITTAG NO was specified
</head>

You may have neglected to close an element, or perhaps you meant to "self-close" an element, that is, ending it with "/>" instead of ">".


Comment:

Line 129, Column 2: start tag was here
<div id="fb-root" style="display: none;">facebook_content</div>


I am investigating it now.


You can download the add-on with changes by the following link: http://cahek.dev.cs-...action=facebook

Kutuzov Alexandr,
CS-Cart Architect Team
Suggest and vote for new features | Report a bug


 
  • jhagg
  • Senior Member
  • Members
  • Join Date: 27-Mar 11
  • 233 posts

Posted 18 April 2011 - 03:18 PM #33

Dear CaHek,

Quote:
Originally Posted by jhagg
This is working well, i believe I have found a bug if you can be so kind to correct it?

When you use "required products" on a product. Click on the required product tab and "be the first of your friends to like this" shows up twice in that tab....probably best to remove it altogether if possible in that tab or at least remove one instance?

Can you help with this?
It was fixed.

I just downloaded latest files and tested, still not fixed....
(pic attached)

The new facebook like it for your option page is too big see pic.

Thank you.

Attached Thumbnails

  • Privacy Policy.png
  • Control4 Programming - Add 1 Room.png


 
  • gugga7
  • Senior Member
  • Members
  • Join Date: 16-Mar 08
  • 277 posts

Posted 18 April 2011 - 08:08 PM #34

Great fixes. Thanks!

one more fix taht has to do with the images published on Facebook and this addon would be awesome ! :)

When I "Like" a product, no image shows at all on my profile

and

When I comment a product, it select images in the page other than the product image (in my case, it shows the captcha in facebook)

Also, there is a small formatting discrepandy "sign in as xxxx" text in the comment" where it shows distorded.

This is great work caHek.

 
  • larous
  • Junior Member
  • Members
  • Join Date: 09-Dec 07
  • 86 posts

Posted 29 April 2011 - 07:12 AM #35

Its any problem with facebook applications?
I am trying to create one and i am getting this error "Sorry, something went wrong.

We're working on getting this fixed as soon as we can."

 
  • JGift
  • Member
  • Members
  • Join Date: 22-Jan 11
  • 97 posts

Posted 02 May 2011 - 01:15 PM #36

I added a new block type called 'Facebook like box'. Now you will be able to place the like box where necessary.



It was fixed.



I added one more type of the "Like it" button. Now, if the 'Button + Comments' type is selected, the "Like it" button and the block with comments will be displayed simultaneously.



I removed displaying of peoples' faces already liking a product.



It was fixed.



It was fixed.



I am looking for the ways how to resolve this problem.



I am investigating it now.


You can download the add-on with changes by the following link: http://cahek.dev.cs-...action=facebook


Hi,

Once you download the rar file, which directories to we copy the files into?

 
  • Flow
  • Super Duper and Amazingly Sexy Senior
  • Members
  • Join Date: 13-Oct 10
  • 2315 posts

Posted 02 May 2011 - 03:58 PM #37

Usually you just copy (merge) the folders from the archive into your main shop directory. It will automatically add the files into the right place.

When life hands you lemons, bring on the Tequila baby!


 
  • gugga7
  • Senior Member
  • Members
  • Join Date: 16-Mar 08
  • 277 posts

Posted 02 May 2011 - 04:07 PM #38

Does anybody know whats the issue with not being able to post the correct product image in Facebook ??

 
  • caHek
  • Architect
  • CS-Cart Architects
  • Join Date: 18-Sep 09
  • 35 posts

Posted 04 May 2011 - 07:23 AM #39

Dear CaHek,
Quote:
Originally Posted by jhagg
This is working well, i believe I have found a bug if you can be so kind to correct it?
When you use "required products" on a product. Click on the required product tab and "be the first of your friends to like this" shows up twice in that tab....probably best to remove it altogether if possible in that tab or at least remove one instance?
Can you help with this?
It was fixed.
I just downloaded latest files and tested, still not fixed....
(pic attached)
Thank you.



Unfortunately, I cannot reproduce this problem. Please download the latest add-on version, install it, and clear the cache. Please let me know if the problem is still actual for you.


The new facebook like it for your option page is too big see pic.
Thank you.



I added two settings to the 'Facebook like box' section of add-on settings: 'Show faces' and 'Show stream'. If both these settings are disabled, only the company logo and the "Like it" button will be displayed in the like box.


one more fix taht has to do with the images published on Facebook and this addon would be awesome ! :)
When I "Like" a product, no image shows at all on my profile
and
When I comment a product, it select images in the page other than the product image (in my case, it shows the captcha in facebook)



The product image is displayed on Facebook now.


Also, there is a small formatting discrepandy "sign in as xxxx" text in the comment" where it shows distorded.


I fixed it.


Its any problem with facebook applications?
I am trying to create one and i am getting this error "Sorry, something went wrong.
We're working on getting this fixed as soon as we can."


Please describe the problem in more details.

You can download the add-on with latest changes by following this link: http://cahek.simtech...action=facebook

Kutuzov Alexandr,
CS-Cart Architect Team
Suggest and vote for new features | Report a bug


 
  • jhagg
  • Senior Member
  • Members
  • Join Date: 27-Mar 11
  • 233 posts

Posted 04 May 2011 - 06:28 PM #40

Unfortunately, I cannot reproduce this problem. Please download the latest add-on version, install it, and clear the cache. Please let me know if the problem is still actual for you.





I added two settings to the 'Facebook like box' section of add-on settings: 'Show faces' and 'Show stream'. If both these settings are disabled, only the company logo and the "Like it" button will be displayed in the like box.





The product image is displayed on Facebook now.




I fixed it.




Please describe the problem in more details.

You can download the add-on with latest changes by following this link: http://cahek.simtech...action=facebook



Both of my problems are solved with this update, thanks!!

How can we control where the like button shows up?