Why Does My Site Want To Go Https?

My site wants to go https when I don't want it to. At the very top left when you log in to your admin, the little shopping cart icon that takes you to your site wants to go to https://
In the security settings I have it set correctly how I want it:
Enable secure connection for the storefront : profile, checkout and order pages
Enable secure connection in the administration panel : checked Yes
Keep HTTPS connection once a secure page is visited: No
It redirects to the non-secure http version which is what I want, but I would like to not have to go through a redirect to get to the proper non-secure version.
Does anyone know where to change this?

You probably need to clear your cache. Use:


and if that doens't work manually rename or remove the folder var/cache