What to do with Smartoptimizer error log

I was wondering for those who use Smartoptimizer, do you ever clear out the “error_log” in the Smartoptimizer folder?

Also, I have been getting the following error on a couple of sites that use smartoptimizer…

/usr/local/lib/php/extensions/no-debug-non-zts-20060613/: cannot read file data: Is a directory in Unknown on line 0
[31-May-2011 09:54:33] PHP Warning: PHP Startup: Unable to load dynamic library

Is there some way to correct the above error or do we just ignore it? From what I can see, if I can figure out what makes the above error my error_log would be pretty much clean. Is anyone else getting the above error?

Jim, I don’t have a smartoptimizer error log (& neither should you)!

Whatever is actually causing this problem needs to be fixed (rather than simply clearing out the log).

This most likely is just one of the issues which attribute to your poor site performance! :wink:

Yep, it could be. Now I’ve got to figure out what is making it.



Yep, it could be. Now I’ve got to figure out what is making it.[/QUOTE]

It “has to” have at the very least some negative effect on site performance.

Yeah, I ended up turning off Smartoptimizer thinking it was part of the issue. Now I realize I have been getting the same error before Smartoptimizer was installed. The difference is now we are able to at least get to the site as when Smartoptimizer was “on” or active it would just “hang” during our busier hours. Sometimes it would be as much as 4 minutes before the site would appear. We are brand new on this server and did not have this issue when we were on the VPSs.

So we got this error resolved. It ended up the host had to “recompile” Apache and all is well. I guess the initial install did not put all of the files on our server or something. So far there is not longer an “error_log” within the Smartoptimizer folder.

I also just realized that doing the “recompile” must have fixed our ability to print a PDF too. I kept seeing errors about some library there too. We were getting an error when we tried to create it and then something was being posted in the main “error” log. Now I can create and print a PDF from the sites on this server.