What the hell? Shipping by Localization NOT WORKING!

Hi all

I have spent 2 days in time on this now. I am loosing my mind.

I simply want to have 2 x shipping methods, defined by Localizations.

So I have created a 30 countiry set as one localization, and the rest of the world list as my second localization.

I have set up my products and menus to view in both.

Now to the BUG / ISSUE / SOFTWARE DOESN'T WORK thing. I have set up UPS realtime to the first localization of 30 countires, and a Custom shipping of 1 US flat rates for the rest of the world Localization. I have called this last localization - 'Contact us for an accurate quote to your country'

Then I login as a customer with a UK address, and fine UPS works, no Custom shipping.

Then I login as a customer with a China address and delivery, and again UPS works and NO Custom Shipping is showing! UPS is not set to work in this China localization.

I was thinking this might be an IP thing, and CS Cart is reading my IP, but I tried to swop it round and set UK as not UPS, and it still only shows UPS.

Then I disabled Localizations, and both Custom and UPS came up as Shipping Methods, so my Custom is working.

It looks like there is a bug in the software to me. Anyone else had this, and how can I get around it.

BTW I also tried selecting all localizations in Locations settings window, just to be sure. It made no difference to the problem.


It is usually helpful to display screen shots of your individual shipping method settings as well as your locations settings when trying to decipher shipping setup issues.