Upgraded from 2.2.5 to 4.02. No problems, now How do I point my domain to the new installation?

Upgrade went well after we changed to a VPS server. Store import completed without a hitch. Took less than 30 minutes. This is all good. I did have to redesign some aspects of my new store, but that was not a big deal.

Now I want to live with the new version, but I can't seem to get the domain to point to the new install. Any ideas?

Make sure you check with your hosting to see if the DNS is pointing to the right location. What happens when you type the domain? Are both stores in the same VPS?You can also look at the config.local.php and see where that is pointing to. Maybe this will help you

[url=“CS-Cart Documentation — CS-Cart 4.15.x documentation”]CS-Cart Documentation — CS-Cart 4.15.x documentation

Thanks for the reply.

The DNS is pointing to the right location. Yes, both stores are on the same VPS, just in different folders. I've tried following those instructions and yet no change in results. This should not be so difficult.

In cpanel, you should be able to set the “Document Root” for the domain. Just set it to point to the proper folder and then edit up the companies in the admin area to get rid of the sub-folder designation and also change config.local.php to set the $config['path'] = '';

Thanks for the reply, but I cannot find anywhere in cpanel to set the document root for the domain, unless it's a parked or add-on domain.

Your host can better help you. Or you can swizzle them if you put your sub-folder in a sibling position. I.e.

/home/foo/public_html - your current document root for your_domain.com

/home/foo/public_html/new_site - original sub-folder

/home/foo/new_site - your V4 site


cd /home/foo

#mv public_html/new_site .

mv public_html public_html_old; mv new_site public_html


Then adjust /home/foo/public_html/config.local.php and the company domains in the admin area.

I finally resolved this issue. Could not get it to point to my 4.2 install folder, but renaming the old install folder and making a redirect solved it.


We've been upgrading some stores last week following the suggested route: install version 4.0.x to a new directory, perform the store import procedure, and finally move this directory to the production directory (be it the root of the domain or not).

When moving to a new directory, we found that the instructions on the knowledgebase article: http://kb.cs-cart.co…other-directory were'nt working.

After some trial and error we did the following:[list=1]

[]Before moving the files to the new directory, in the admin area, edit the store's “Storefront URL” and “Secure storefront URL” and type the new path (for example domain.tld/new_directory)

]Save these changes

[]Move the files to the new directory and follow the instructions of the knowledgebase article.

]Finally, go to the admin area under the NEW directory and clear cache, using ?cc, ?ct, or directly deleting the files on the var/cache directory.


These worked for us. We did not find any issue related to any addon, for that purpose.

Hope that helps somebody. I'll be grateful if anyone can clarify and be more precise than me, I am not sure why it worked in our case, but it did.