Updating Products Price And Quantity Via Feed


I was trying to export Google base data feed and noticed that a CSV export with commas as separator makes the output file out-of-spec.

For example, when a column has product description sentences and they have commas in the paragraph then each comma results in a new column in the exported file - and that breaks everything.

Looking for a solution. Please help.

Thanks in advance.

PS: searching these forums did not show any relevant solutions yet.

Can you try and use semi colon as seperator

Hi jon,

Thanks for the suggestion.

I already tried that after creating this thread and the other 2 delimiter options - tabs or semicolons - also failed to export the data correctly.

Any other workarounds? Or if the developers are reading it, I would love to hear from them.


So, do you mean when you open it in your spreadhseet software it appears like this or when it goes direct to google.

I had it a few times, where opening in the spreadsheet wouldnt format properly, so i right clicked the file renamed it from .csv to .txt

then opened it by opening my spreadsheet software, then choosing file>open>delimiter as comma or tab and then resaved this way.

Maybe same could help

John, thanks again for your suggestion.

Commas and semicolons did not work correctly, one way or another. This needs to be fixed by MV developers, i believe.

Tab-delimited export worked but only when "importing" it as a text source into spreadsheet.

Though I would say these should be in the correct specification - to reduce overall number of steps. (and save time!)

If you are using the data feed addon, you need to add " for the enclosure.

[attachment=13899:Screenshot_2019-07-11 Add-ons Data feeds - Administration panel.png]

Screenshot_2019-07-11 Add-ons Data feeds - Administration panel.png

Can you actually also add or substract quantities, instead of overwriting current quantities? That would make so much sense with stock updates.

Tool, tyvm!

Thie spreadsheet started making sense as soon as the cell data was enclosed in quotes in the CSV - exactly what was needed.

TYVM indeed.

If you are using the data feed addon, you need to add " for the enclosure.

attachicon.gif Screenshot_2019-07-11 Add-ons Data feeds - Administration panel.png