ultimate 3.0.3 problems with smarty

Hello,



I have CS-Cart Ultimate 3.0.3. I've added two stores and they are working perfect - I didn't meet any problems with them. Now I'm trying to add third one store and after instalation I have error code in amin back end “The customer area skin defined for the selected company is not found. Please follow this link admin.php?dispatch=skin_selector.manage to select a skin for the company.” (need to say, that template are chosen and after I'm selecting the new one skin - I have the same error).



After that if I'm trying to change anything in block - for example to add new block with html code (even just to write simple text in it) - I'm getting error code in the place of this block in user back end “Warning: Smarty error: unable to read resource: “/home/admin/domains/…/public_html/stores/9/skins/tshirt/customer/” in /home/admin/domains/…/public_html/lib/smarty/Smarty.class.php on line 1095”



So I'm not able to do with it anything. Need to say, that first and second stores working perfectly - no these kind of problems. The third one and another one (if I'm trying to add more stores) - have these kind of problems.



As for permissions of folders and files - they are all OK.



What could be a reason of this problem?



Thanks you for your help!

Does the public_html/stores/9/ folder definitely exist and does it, along with all subfolders, have 777 permissions?

Yes, it does. And permission for all folders and files are correct. The tricky thing is, that the skin in user back end is working fine at begginning, but it's enought just to add new html block and after that I'm getting error. Also can't understand this line “[color=#282828][font=arial, verdana, tahoma, sans-serif]”/home/admin/domains/…/public_html/stores/9/skins/tshirt/customer/“”, cause “customer” folder exists for sure and it's 777. If not - skin would work at all at user front end :/[/font][/color]

Is that the full error?



Try clearing your cache by adding ?cc to the end of your admin URL, eg. yoursite.com/youradmin.php?cc

Ohhh, it works somehow. I need to clean cach after adding every block to make it work. But still it works now! Thank you very much! I spent 5 days trying to find the solution for it! :)

Glad you got it working, but there's still something wrong. You shouldn't need to flush the cache every time you add a block, if you get any errors displaying, see if they make reference to a particular file. The error you posted earlier would lead me to think a folder did not exist or had inadequate permissions.