turn off ssl outside of admin area

Hi there! Quick question…



A webhost moved an old shop from a friend of mine, which was using SSL. However, the new host does not have SSL installed yet. So I can't get into the admin area.



So I was wondering, is it possible to turn off SSL through FTP?



Thanks,



Floris

You will have to disable it via the data base.

Ah, ok, I will try that. Any more hints on what to look for?

cscart_settings Look for the ssl options

[quote name='The Tool' timestamp='1327433555' post='129872']

You will have to disable it via the data base.

[/quote]



how to turn it off through database at v3.0.6 ? thank you

Should be in table cscart_settings. Not sure exactly what line.

Hello!

Same question here: how to turn off secure connection in CsCart V4.2.2 without the capability to login to store backend?

I am working on the clone in a test environment with full access to server and database.

The suggested remedies did not work for me:

1) database:

a) secure_admin to N in db table settings_objects

b) updating secure_storefront in table cs_companies

2) config.local.php: setting $config['https_host'] to the same domain as $config['http_host']

3) clearing cache

When calling the store backend login file, it always redirects to index.php at https://domain.com...

Grateful for any advice and support!

If you have this as a subdirectory (versus a subdomain) then it should work with your current certificate. If not (I.e. using a subdomain) ensure that cPanel is not applying your base certificate to this subdomain.

Are you clearing the cache manually by renaming/removing var/cache?

Make sure the 'secure_storefront' value is also set to 'N'.

Then manually clear the cache.

Hello!

Same question here: how to turn off secure connection in CsCart V4.2.2 without the capability to login to store backend?

I am working on the clone in a test environment with full access to server and database.

The suggested remedies did not work for me:

1) database:

a) secure_admin to N in db table settings_objects

B) updating secure_storefront in table cs_companies

2) config.local.php: setting $config['https_host'] to the same domain as $config['http_host']

3) clearing cache

When calling the store backend login file, it always redirects to index.php at https://domain.com...

Grateful for any advice and support!

if it sill does not work, PM me temporary FTP access. We will try to find a reason of the issue

Hello Ez, hello eComLabs,

thank you so much for the quick advice!

Setting secure_storefront in cscart_companies table to "N" indeed did the trick.

(the current version v4.5.2 seems to have a more tolerant fallback when given the same url than storefront, so I wrongly assumed that for v4.2.2 as well).

I am now able to access store backend without the ssl certfificate, this issue is solved.

Thank you again!

Thank you for keeping us updated!