Time Zone Confusion

Can’t seem to get my store to show correct time. In settings I have GMT selected but since the clocks went forward my store is an hour behind, I have tried manually changing the setting to GMT+1 but this adds two hours, ie puts my store forward an hour more than I want.

I have read previous posts on time zone issues but can’t figure out what’s going on now - I’m presuming that the store is automatically adjusting to allow for daylight saving times, but this isn’t working on GMT, so therefore there isn’t a time zone I can select which would put my store right!!!

Or am I totally missing something simple here???

I have tried to explain to CSC that using the GMT+/- format does not adjust for time changes. I am not sure what it is for your location but here are the examples for Europe:

Europe/Amsterdam Europe/Andorra Europe/Athens Europe/Belfast Europe/Belgrade

Europe/Berlin Europe/Bratislava Europe/Brussels Europe/Bucharest Europe/Budapest

Europe/Chisinau Europe/Copenhagen Europe/Dublin Europe/Gibraltar Europe/Guernsey

Europe/Helsinki Europe/Isle_of_Man Europe/Istanbul Europe/Jersey Europe/Kaliningrad

Europe/Kiev Europe/Lisbon Europe/Ljubljana Europe/London Europe/Luxembourg

Europe/Madrid Europe/Malta Europe/Mariehamn Europe/Minsk Europe/Monaco

Europe/Moscow Europe/Nicosia Europe/Oslo Europe/Paris Europe/Podgorica

Europe/Prague Europe/Riga Europe/Rome Europe/Samara Europe/San_Marino

Europe/Sarajevo Europe/Simferopol Europe/Skopje Europe/Sofia Europe/Stockholm

Europe/Tallinn Europe/Tirane Europe/Tiraspol Europe/Uzhgorod Europe/Vaduz

Europe/Vatican Europe/Vienna Europe/Vilnius Europe/Volgograd Europe/Warsaw

Europe/Zagreb Europe/Zaporozhye Europe/Zurich

Well I just had a look at the database and it looks like they did take my advise. You should be selecting “(GMT) Greenwich Mean Time : Dublin, Edinburgh, Lisbon, London” which is “Europe/London”. Maybe it was not updated in 2.0.10?


Thanks for the reply.

[quote name=‘BarryH’]“Can’t seem to get my store to show correct time. In settings I have GMT selected” [/QUOTE]

It hasn’t added the hour automatically and selecting +1 adds two hours, which seems as though the +1 has updated with the extra hour automatically???

If it doesn’t show “B Greenwich Mean Time : Dublin, Edinburgh, Lisbon, London[/B]” in the settings dropdown, then I would have to say that your database has not been updated.


Thanks again

My dropdown option is GMT Greenwich…

So obviously NOT updated.

Is there a way to update that one time zone as that is all we use?

Thanks in advance

In phpMyadmin go to table cscart_settings_variants and select browse. I do not know how much has changed but the variant_id should be about 10258 or just look for the variant_name which is probably Etc/GMT and change it to Europe/London.


Kind of managed that. Thanks very much for your help.

It is correct time now.

:stuck_out_tongue: :stuck_out_tongue: :stuck_out_tongue: