Thumbnails not creating

For some reason, thumbnails are not creating anymore. I don't add products often to the shop…

I've run https://domain/admin.php?ct - now no products have thumbnails at all.

I've double checked, GD etc is all installed (Ubuntu, Apache).

Images directory (and subdirectories) permissions?

Yes almost definitely permissions, I had it recently when I uploaded the files after the thread on here about stripping out meta data.


How the hell did I miss that? Thanks, all fixed :D


I have the same problem, thumbnails are not creating for product pictures. I can't see them either in the admin panel or in the storefront.

I use: - Ubuntu 12.04.3 LTS (GNU/Linux 3.5.0-41-generic x86_64),

- Cs-Cart 4.0.2 Trial version,

- Apache 2.2.22 (Ubuntu),

- PHP 5.4.20 (I tried PHP 5.4.19 and I had the same problem),

- MySQL 5.5.29-0ubuntu0.12.04.1 (Ubuntu).

I changed the permissions to 777 recursively, for users administrator, root and www-data, one by one. For each user I tried adding a picture to a product and the thumbnail didn't create.

I tried doing this in Windows with XAMPP and it worked. But I need it to work on Ubuntu as well.

I noticed that in Ubuntu there isn't a '/images/thumbnails' folder like in windows. I created it manually in Ubuntu, created the structure: '/images/thumbnails/160/160/detailed/5/mypicture.jpg' and the thumbnail finally appeared. But I can't do this every time I create a product. I have several hundred products to add.

With the file structure mentioned above I tried adding another product with image and didn't work. It deleted '/detailed/' folder from '/images/thumbnails/160/160/' that I created manually earlier.

Please help me with this issue in Ubuntu.

Update: I installed a new instance of Cs-Cart 4.0.2 (with sample data) on the Ubuntu platform mentioned above and there are no pictures showing for the products anywhere.