Thumbnail Issue - Anyone seen this?

Hi everyone, I was wondering if someone had ever seen this and knows of a way to fix it.

Here is the scenario - we have products that have images for both the thumbnail and the full sized. I can see that the system uploaded them correctly, but whenever you “click to view larger image” it still only shows the thumbnail.

The screenshot shows that it's drawing from the “thumbnails” path and not the “detailed” path. I've tried it a couple different ways but I've been unsuccessful in figuring out if I have a problem in the template files or if I'm messing something up in the configuration.

Screenshot here

Thanks in advance!

First time for this one, but I am wondering how you are uploading your images?

All you need to do is use ONLY the “Popup Larger Image” uploader. Be sure to only upload your large image.

The thumbnail is only used if you want to override the CS-Cart created thumbnail.

Also, be sure to check you setting under Settings => Thumbnails.

Hope that helps,


Hi Larry, maybe check in the admin page - settings - thumbnails

Good luck.


I see you have version 2.1.2 . That means that Cs-cart handles all the thumbnail creation unless you uploaded a different one.

But the picture in the product description is also created from the original if you have dimensions in the thumbnail page of administrator.

So go over there and check the dimensions for product Detail page width and height. Put something like 200 in both if you want to control it by width and height.

Thanks for the replies guys… this is still really odd - it's like it's reversing the role of the thumbnail for the “see larger image”.

I did what you suggested by modifying the detail page TN, but it's still not behaving the way I'm thinking it should. See the following to get a feel for what I'm doing:



Am I doing something wrong here or is this genuinely screwed up do you think?

Here is the link to the actual page and you can see how it's acting.

You have your detailed product image width set at only 70px, set this higher than your thumbnail width.

The link is showing the detield image has been loaded as a thumbnail in your import so your probably better bringing in the detailed images in again via import but try the size adjustment first see if it is pixelated


Exactly, and to be sure clear that cache…

Ahhhh man, I swear you look at the same page 10x and you just don’t see it :) I kept seeing “thumbnail” and didn’t notice that image was NOT the thumbnail but the detailed. Really appreciate the enlightenment and humoring my moment heh.

done it myself many times man…no worries :)