Stripe Connect Error

Hi everyone,

I am setting up stripe connect on the marketplace and currently in test mode.

I have input all the data but at checkout I am getting 'no payment methods available', going back to the vendor profile (mine in admin mode) it is showing as stripe not connected and no option to connect?

We tried creating a test vendor account but the same problem on there.

When we had it in live mode it gave us the option to proceed at checkout but in test model no luck.

Is this due to us being admin?

Thanks

Hello,

If I understand you correctly, you are not able to connect vendor with Stripe.

The button "Connect with Stripe" in vendor management is available only when logging in as Vendor. Use option "Act on behalf of" to do it faster, without asking vendor for credentials.

Once at least one vendor will connect with Stripe, a payment method in test mode should appear.

Best regards,

Robert

I'm also having issues with the 'Stripe Connect' Addon. Acting as a vendor administrator , when I click the button 'Connect with Stripe' I get the following error:

{"error":{"message":"No application matches the supplied client identifier"}}

I really have no idea what this means! Any ideas?

Hello,

I think you have typed wrong client_id into payment configuration. Account ID is not a client ID.

To access client ID, you should go into menu Settings -> Connect settings. https://dashboard.stripe.com/account/applications/settings

Best regards,

Robert

Please find more details here

https://docs.cs-cart.com/latest/user_guide/addons/stripe_connect/credentials.html

There are many reasons, for a charge can fail: Credit card get expired. Bank account get insufficient funds. Does not match ZIP code.

Please find more details here

https://docs.cs-cart.com/latest/user_guide/addons/stripe_connect/credentials.html

I've followed all of these instructions but still getting the same response


Hello,

I think you have typed wrong client_id into payment configuration. Account ID is not a client ID.

To access client ID, you should go into menu Settings -> Connect settings. https://dashboard.stripe.com/account/applications/settings

Best regards,

Robert

Yep have copied the client ID from stripe into the cs cart stripe connect payment method. Any other ideas??

Hello,

Have you also correctly copied publishable & secret keys? If you have messed those two keys, or you're using production keys with test client ID, you'll always get an error.

If you are sure that you typed everything correctly, it means that issue is more complicated, and I'd need access to your store in order to try to resolve it.

Best regards,

Robert

Hello,

Have you also correctly copied publishable & secret keys? If you have messed those two keys, or you're using production keys with test client ID, you'll always get an error.

If you are sure that you typed everything correctly, it means that issue is more complicated, and I'd need access to your store in order to try to resolve it.

Best regards,

Robert

Yeah I've tried it so many times, copying across just in case there has been a mistake but can't seem to get it to work. Would you be able to have a look?

i also having same problem, i have setup stripe connect using test mode. and vendor we setup stripe connection too. but on storefront checkout, the stripe payment method is not showing.

is using stripe test mode key not allowed ?

i also having same problem, i have setup stripe connect using test mode. and vendor we setup stripe connection too. but on storefront checkout, the stripe payment method is not showing.

is using stripe test mode key not allowed ?

Vendors of all products form the cart should be connected to Stripe. If at least one vendor is not connected, Stripe method will be hidden