Store Import V3.0.6 To V4.3.9 Stuck

Well, I have been trying for three days and I have been through CSC support which has been less than stellar. I am hoping someone out there has had a similar problem and found a solution.

No more errors in PHP, apache etc.

max_execution_ time 3600

max_input_vars to 100000 - at 1000 I was getting an error

memory_limited 1024M

default_socket_timeout 120

FastCGI timeout 10minutes

most of this was at the recommendations of CSC support.

Still failing - The failing mode is that it simply stops dead. No redirect or errors. It stops at

Upgrading to 401 - Converting orders

I have cleaned logs, search history, optimized database etc.

My V3.0.6 store is live and I have tried closing the store while doing the import. I have tried closing the store and disabling all addons. All other addons that are not normally active are uninstalled. Nothing changes the problem. The store has 2079 products and the database is 112MB.

I am willing to go manual but I am told I won't be able to link up the orders to customers and what not so basically I would loose all of that data by going manually.

I have 3 active CSC licenses with continual upgrade subscriptions and I buy support credits which they have used for support of this issue which really is out of my control so I am not sure why I am being charged for it. I have been a customer for 5 years. Truly frustrating.

Anyone have a dart they want to throw??



Do a manual backup. Clear the logs table and the new orders table (might be different name, I’m on phone right now so can’t look). Then go into the store_import code and comment out anything related to backup (could be a property setting near the top too). Then try again. Sorry for the vague descriptions but no codes in front of me.


Thanks for the response. Seems that the import is passing the the areas you are suggesting bypassing.

The Import Passes - Backup

The Import Passes - Cloning Database

The Import Fails at - Upgrading to 401 - Converting Orders


Make sure you do NOT have DEBUG enabled.

Anything in error_log or access_log? Access_log should show the exit status of the apache process (probably a 500 status).

Just an update here.

CSC Support looked at my server (which is a dedicated server) and could not figure out the issue with store import. They recommended I migrate my V3.0.6 store to local pc and install V4.3.9 locally then try to import on my local PC. This worked fine. Note: There is only 1 version of XAMPP out there that is compatible with both V3.0.6 and V4.3.9 and it is Version 1.7.7 which has PHP 5.3.8

Update: I migrated to a new server and used MYSQL 5.6 instead of 5.5 which solved my issue. Do not know if the culprit was the server or MYSQL though. It works now though.