Store import from 3.0.6 to 4.0.2 fails help!


I've just installed 4.0.2 and everything seems to install ok. The problem is that when I use the store import tool to convert from 3.0.6 to 4.0.2 it looks like it imports everything, but no products appear. It says cloning database and importing data, but its not actually doing anything.

And when its finished, it hasn't progressed to the next step, it just gives me the option to push the import data button again which no matter how many times I import, it doesn't go further.

It also takes about 20 minutes to import nothing…

Anyone got any suggestions or ideas? Its driving me crazy

l'm having this same issue. I contacted support and they have no idea why it's doing this. They guess, and ask me to try things, but they don't have a clue which is VERY frustrating!

It IS pretty frustrating…

If you find a way to get it to work could you reply again ?

Same here. Import from 306 hangs

I am having the same problem. Are there any solutions or recommendations to get the store import to function correctly?

I still cant find a solution to this…i've tried everything I can think of, its poorly made with no testing like everything cs makes

After trying everything from increasing the memory limit in config.local, increasing my servers limits to more than it should be, and applying their general.php an mysqli.php files it still fails. I've tried deleting all statistics and logs from the old 3.0.6 install, disabling and removing the SEO addon(including emptying the db table for them) I've come to the conclusion that this is just not going to work for me. Very frustrating! My old 3.0.6 has a DB size of 320mb, which isn't that big as far as databases go. The backup part of the import runs, and then it hangs when trying to import the data. Giving up for now, this isn't working. Are there only a few that have this issue? Is the import just not made for more than 1000 products?

My problem was solved after upping memory_limit and max_execution_time

I tried to up the memory in config.php, I tried the addon files (general.php and mysqli.php), I just can't get it past the import data stage, it looks like its importing, but after if finishes, it just goes back the the timeline thing for the store import and the only button I can hit again is import data. Ive read all the threads and tried everything suggested, but still no go

I'm having a similar issue now (from 3.0.5 to 4.0.3) it stops at 'Converting Orders' every time.

I've tried upping memory_limit and max_execution_time. No difference.

It's very frustrating, as it worked fine for me a few weeks ago. I need to do a new installation and it's not working now.

Anyone found a solution???

I'm having the same problem upgrading from 3.0.6 to 4.0.3. I have tried everything but no luck, it is [font=“arial, verdana, tahoma, sans-serif”][color=“#282828”]VERY frustrating! And the worst part is the CS-Cart team couldn't care less! I'm all ways running to problems with CS-Cart, i just don't see why they are always changing the software to a new version if they [/color][/font]can't even get the correct one to work as its meant to… Guess its all about the money and less about the quality for them!

Finally solved it!!

During 'Converting Orders' it always failed at the same orderId, so I thought it was a memory or limit issue. In my server logs i kept getting…

PHP Fatal error: Allowed memory size of 1073741824 bytes exhausted (tried to allocate 523800 bytes) in /var/www/html/cs-cart_test403/app/Tygh/Backend/Database/Mysqli.php on line 107

I allocated more memory in \app\addons\store_import\Tygh\StoreImport\General.php

at line…

1284: ini_set('memory_limit', '1024M'); <----increased this

It DID NOT help - kept getting…(tried to allocate 523800 bytes)

I ended up editing…


I just changed…

protected function _convertOrders()
$limit = 50;


protected function _convertOrders()
$limit = 20;

Hope this helps someone. It was very frustrating and took me forever to figure out.

I tried all of that but it didn't work. I contacted support team and they tell me thats its a [color=#282828][font=arial, verdana, tahoma, sans-serif]memory_limit issue, but i all so tried that, i [/font][/color][font=“arial, verdana, tahoma, sans-serif”][color=“#282828”]increase the [/color][/font][color=#282828][font=arial, verdana, tahoma, sans-serif]memory_limit [/font][/color][font=“arial, verdana, tahoma, sans-serif”][color=“#282828”]and [/color][/font] max_execution_time on the server but again still doesn't work. Its really [font=“arial, verdana, tahoma, sans-serif”][color=“#282828”]frustrating and to be honest i just don't see why its so hard to import from one to the other. [/color][/font]

[font=“arial, verdana, tahoma, sans-serif”][color=“#282828”]Been at this for the last 4 days, i'm ready to give up and import it to a deferent shopping cart that actually works.[/color][/font]

Were you ever able to get this issue resolved? I have tried everything I have found on the forums and I still can not Import my old cart. The import runs for a while then I get dumped back to the “Validate and import” screen, with nothing imported.

the only thing that worked for me was changing the file [color=#282828][font=arial, verdana, tahoma, sans-serif]F306T401.php, mentioned in my post above. i was going from [/font][/color][color=#282828][font=arial, verdana, tahoma, sans-serif]3.0.5 to 4.0.3.[/font][/color]

Don't know if you've tried that.

Other than that and the other memory increases people have mentioned I don't know of any other solution sorry

Thanks for the suggestion, I did give your suggestion a try with no luck. I also increased the memory, optimized the database, and dropped the stats and logs from the DB.

Was having this issue here, too. Trying to import from 2.2.4 to the newest version always failed.

Finally had success importing to 4.3.1 beta 2. Not sure if something got fixed in the code or not.

The only other two changes that possibly helped were: 1) updated PHP, and 2) updated MySQL. The newer versions are supposed to run faster, and it's possible that those upgrades helped things along.

We suggest you to make upgrade on the local server. The import may fail due to server restrictions, especially on the shared hosting.

I did it!!!!!

I've try everything I found on forums without luck.

I just update from php 5.3 to 5.5. The store with cs-cart 3.0.6 not running but was able to import all the data to 4.1.2