Slow admin

Since upgrading a week ago my site and admin is extremely slow. I am receiving this error when I want to change the quantity of 10 items. 2 weeks ago I was able to do 1500 at a time. Hostgator assures me they did not make any changes.


Fatal error: Out of memory (allocated 68681728) (tried to allocate 47 bytes) in /home/xxx/public_html/ on line 101[/color]

Please. Where is my problem?

I've been running into a similar problem on 2.2.3. I know Nicol is using the MV edition and I'm using the Pro. One of my site is especially bad with this and the other isn't nearly as bad, but still slow.

I've tried all sorts of things that were suggested here on the forum like modifying my php.ini and stuff, but I still am having problems.

I was the one that upgraded Nicol's site and of course I did my own. I just did it with the upgrade script through the admin so nothing fancy.

Anyone have any ideas?



could this be similar?

I figured that was pretty similar, but I was hoping someone had a solution. Maybe I'll post on there and see if CS-Cart can provide the fix instead of just saying “fixed in next version” A lot of good that does us now.



i'm constantly receiving error occured pages when trying to edit bulk products or doing anything which takes a little while like upload images etc. All my chmod's are correct on the server too, and i'm running 2.2.2!


Why is there nobody else having the same problem as us!

Oh, there are plenty having the issue. Some don't realize it yet. Others just do not bulk edit. Some will only do one item at a time. We have confirmed that we have pretty much the same issue in the bug area. So you are not alone.

Jim has it right as far as I am concerned. I only do imports. I did try the bulk edit a couple of weeks ago just for shits and grins and all I got was the blank page.

Other than the bulk editing, my admin in general runs just fine.

Edit: Maybe the topic of the thread should be “Screwed Up Bulk Edit” instead.?

@nicol, @brandonvd, etc.

Same problem here after upgrade to v2.2.3. Still looking for a solution…

2.2.3 pro

I'm also having this problem. Can't seem to use more then 128 kb when bulk editing, no matter how I change the settings.


if this is a typo and it's 128MB, then try to disable the mailchimp addon if you have it and see if the issue still exists. In several addons I create, it attempts to INCREASE memory to a certain level (128MB for mailchimp).

If the problem goes away, please drop me an email at (remove X's) and let me know what the value of 'addon_version' is in addons/mailchimp/config.php. The current version should be 2.2.15.

While I believe it is behaving correctly, I don't find too many other places where the memory_limit is adjusted dynamically other than webmail, couple of my addons. But like I said, it is “supposed” to only set it if a ini_get('memory_limit') returns less than the value it wants to set it to.

Update: I just tested the current version of mailchimp (above) and it works as intended. I.e. if memory_limit is less than 128M then it sets it to 128M and if not, it does nothing.

Oh well, it was a thought.

Approximately 5300 products in my store using 2.2.3, however, when I try to view 50 products and select for bulk editing, then only select features to bulk edit, I get this same error:

Fatal error: Allowed memory size of 536870912 bytes exhausted (tried to allocate 82 bytes) in /home/username/public_html/core/db/mysql.php on line 101

This is running on a dedicated server, with more RAM than I know what to do with. I increased the config.local.php memory limit up to 64M, then 128M, then 256M then 512MB, and finally, 1024M, still the same.

Anybody manage to resolve this, or was a fix provided in 2.2.4? Strangely I can bulk edit in my 2.2.4 store, however, this store has 0 customers, 0 orders and a little less than 100 products so far.

Something is wrong. Suggest you contact the helpdesk and have them look into it.