Skin problem with Ultimate


First thanks for all the forum notes that have helped me so far. This is appreciated.

I am trying to set up an Ultimate version for my online shops to simplify management of these as many have the same products. I have to copied the basic skin and created a version I will use with my changes. Keeping the basic one as the detault. I copied the basic from the /var/skins_repository directory and resaved it under a new name. Created a new customer_screenshot.png and amended the manifest.ini to hold the new name.

Set up file permissions as suggested. I have not checked every folder as there are so many however I did apply to subdirectories.

Went to one of my stores and selected the new skin and saved. It loaded this into stores/3/skins/decorheaven. However when then going to the live store the category page does not load correctly.

There is an error message after the sub-categorylinks.

Unable to read resource: and gives the directory ending in stores/3/skins/basic/customer//products_multicolumns.tpl

This occurs on both shop fronts.

Unable to read resource:-------/shop/stores/1/skins/basic/customer//products_multicolumns.tpl

When you revert to the basic version the problem disappears for both shops.

Have removed and tried again 3 times.

Any suggestions please, Thanks heaps!!

You might have to re-save your blocks and/or any layout specifications you have set in the product or category pages under “layout”.

[quote name='tbirnseth' timestamp='1364527665' post='158918'] You might have to re-save your blocks and/or any layout specifications you have set in the product or category pages under “layout”. [/quote]

Thanks tbirnseth

I am not sure where you mean by “layout”. I do not have any folders called that I can see or menu items from the admin BOH called this. I have not altered any of the blocks layouts at all yet - well at least knowingly - unless it was indirectly by making another selection in another area.

The missing file - products_multicolumns.tpl - does appear in …customer/blocks/products in all the skins under /stores/1/skins, /stores/2/skins & /stores/3/skins and the var folder too.

Each category and product page has a “Blocks” tab. This controls the layout for that specific product. If you have set this to anything other than parent (or default) then you might have to resave the product to get the block definition related to the new skin. Not absolutely sure, just trying to give pointers of what you might try.

tbirnseth, totally appreciate any hints like this. It matches how I go about this so totally understand the hints situation. I found the blocks and tried to resave. Then discovered the errors occur only in categories that have products. Now I am deleting and trying a total reinstall.