Site Not Appearing In Google At All After Several Months


I have had a site in development but publicly viewable for several months and have set up a couple of social media accounts with links to it and would have expected to see something appear in Google when searching for the URL but Google just doesn't see my site at all. I am not expected traffic or anything, I just suspect there is a problem with how I have the site set up causing it to be invisible.

Can anyone help? The site is [url=“”][/url]

It's the latest version of multivendor

Do you have things set up with Google Webmaster Tools and Bing Webmaster Tools? For us, we had to end up buying the add-on from CSCartRocks at…

CS-Cart SEO Ultimate: Canonical URL + Google Rich Snippets + SEO Name History + More

…because CS-Cart out of the box is awful on the seo side. CS-Cart says they are adding things to fix this in version 4.2 but who knows how long before that comes out and then how long it will be stable.

Looked at Webmaster tools for the first time in about 6 months and apparently the homepage is showing as a soft 404. I'm not sure what to do about that.

Do you have a robots.txt file? If so it probably contains:

User-Agent: *

Disallow: /

You should remove that.

Your site is not showing at all so this has nothing to do with cs-cart being “awful” on the seo side - it really isn't all that bad Jim!

Nice site btw!

I confirm :mrgreen:

User-agent: *

Disallow: /images/thumbnails/

Disallow: /app/

Disallow: /design/

Disallow: /js/

Disallow: /store_closed.html


If your getting a soft 404 has your site had outages? was it being redirected at some point.?

You must use webmaster tools, verify the site again, submit a sitemap and more importantly fetch as google your home page and see what the response code is.

THEN, manually submit a load of urls and see what you get.

I checked your site and not 1 single page has been crawled/listed…Goog doesnt even know the homepage exists. Submit the homepage url via webmaster tools and check the all linked urls box to start with


Thanks. I think the robots.txt was the issue. It's very annoying that it was something very simple and yet should have been right by default and so I didn't consider it.

I'll give it a week and see what happens.

Disallow: /design/ > no : the problem

Disallow: /design/backend/ /* only this should be better



HomeMixed fruit & veg boxes null null null !!

you want it to index ?

I have given it a few weeks the homepage now doesn't show as a 404 but still do and I still can't see the site in Google's index.


Just checked my httaccess to see if there's anything obvious. Any ideas?

DirectoryIndex index.html index.php

AddEncoding gzip .gz

RewriteCond %{REQUEST_FILENAME} .(js|css)$

RewriteCond %{HTTP:Accept-encoding} gzip

RewriteCond %{REQUEST_FILENAME}.gz -f

RewriteRule ^(.)$ $1.gz [QSA,L]


ForceType text/css

Header set Content-Encoding: gzip

Header set Cache-control: private


ForceType text/javascript

Header set Content-Encoding: gzip

Header set Cache-control: private

Header set Access-Control-Allow-Origin "

RewriteEngine on

Pleas note that RewriteBase setting is obsolete use it only in case you experience some problems with SEO addon.

Some hostings require RewriteBase to be uncommented


Your store url is

So “RewriteBase” should be:

RewriteBase /store/cart

RewriteBase /

Options -MultiViews

RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

RewriteRule api/(.)$ api.php?_d=$1&ajax_custom=1 [L,QSA]

RewriteCond %{REQUEST_URI} .(png|gif|ico|swf|jpe?g|js|css|ttf|svg|eot|woff)$ [or]

RewriteCond %{REQUEST_URI} store_closed.html$

RewriteCond %{REQUEST_FILENAME} !-f

RewriteCond %{REQUEST_FILENAME} !-d

RewriteRule ^(.
?)/(.*)$ $2 [L]

RewriteCond %{REQUEST_FILENAME} !-f

RewriteCond %{REQUEST_FILENAME} !-d

RewriteRule . index.php [L,QSA]

I did wonder if I neeeded to uncomment the rewritebase line.