Site News block too long

Hey everyone.



I know how to limit the amount of news feeds to display in the main “site news” block, but when someone clicks on one of the news links to view it, it redirects to the main “site news” page which has a block on the right with ALL the news I’ve ever posted since the beginning! And it’s getting pretty darn long.



Is there a way to limit how many are displayed on that specific block?



Here’s the link to my page and you can see when you click on one of the news feeds on the right.



http://www.fishtail.ca



Thanks.

One simple thing you can do is to deactivate all your old news (content/site news) so that in that page only the most recent ones appear.

Under that block click on ‘edit’ then ‘specific settings’. There is a limit field. Set it to what you want.

It’s already set to limit of “3”…which is only affected on the homepage for some reason…?

I fixed it! I put in another number in “specific settings”, then put it back at 3, and it works!



That’s weird. It seems like it was a glitch.



Thanks everyone.