Seo Url Rewrite, Can't Get It To Work!

Hi all

I am stuck. I have 3 CS-Cart installs on my web server at Media Temple, no problem with the SEO URL rewrite. Those carts are in 4.2.3.

I have a fresh instal of 4.1.2 on the same server, it runs fine. BUT I can't get the SEO rewrite add on to work. I say in admin 'not enabled, please check your server settings'. However I have put a htaccess file in the cart root as my other sites, added the code below with my new cart address. No go.

I have tried taking out the comments, just leaving rewrite on and the path, then no path. Nothing works. I tried the shop closed code test and that runs fine (shop says closed).

What gives? I really want the URLs to change to help in Google. Any help would be great guys.

Here is the full code (which didn't work) The file is set to 644 permissions. The Cart is in a sub folder so www.mydomain/shop

AddHandler php5-script .php

DirectoryIndex index.html index.php

RewriteEngine on

# Some hostings require RewriteBase to be uncommented

# Example:

# Your store url is

# So "RewriteBase" should be:

# RewriteBase /store/cart

RewriteBase / shop

RewriteCond %{REQUEST_FILENAME} !\.(png|gif|ico|swf|jpe?g|js|css)$

RewriteCond %{REQUEST_FILENAME} !-f

RewriteCond %{REQUEST_FILENAME} !-d

RewriteRule . index.php?sef_rewrite=1 [L,QSA]

RewriteCond %{REQUEST_FILENAME} .*\/catalog\/.*

RewriteCond %{REQUEST_FILENAME} -d

RewriteCond %{REQUEST_FILENAME}/index.html !-f

RewriteRule . index.php?sef_rewrite=1 [L,QSA]


Try to comment our the following code and check if SEO works correctly

        if (strpos($headers, '200 OK') === false) {
            $new_value = 'D';
            fn_set_notification('W', __('warning'), __('warning_seo_urls_disabled'));

Remove the space between the forward slash and shop. However, you should set it up as a sub domain instead of just a sub folder.

Thanks guys. The eComLab suggestion worked. Seems ok now, no idea why the admin came back with an error.

You are welcome! Please pay attention to post #3 also. RewriteBase should not contain spaces between slash and subdirectory name