Seo Addon Issues

Hey Guys,



back again…



I think I've fixed this issue before but I can't exactly remember how I fixed it.



Everytime I activate the SEO addon from the addons page I get “Service Unavailable” pages everywhere. Mod_rewrite seems to be working, I've turned off Modsec in the server just incase that's the issue, which it isn't.



I'm not sure what else I can do…

I get the following error when loading the page with dev mode.



-----------------------------------------------

Message



Unknown column 'path' in 'field list' b[/b]

SELECT name, path FROM cscart_seo_names WHERE object_id = 0 AND type = 's' AND dispatch = 'index.index' AND lang_code = 'en'

Error at



app/Tygh/Database.php, line: 677

Backtrace

File: app/Tygh/Database.php Line: 333 Function: _error File: app/Tygh/Database.php Line: 158 Function: query File: app/functions/fn.database.php Line: 54 Function: getRow File: app/addons/seo/func.php Line: 816 Function: db_get_row File: app/addons/seo/func.php Line: 1125 Function: fn_seo_get_name File: app/functions/fn.control.php Line: 84 Function: fn_seo_url_post File: app/functions/fn.common.php Line: 3281 Function: fn_set_hook File: app/addons/seo/func.php Line: 971 Function: fn_url File: app/functions/fn.init.php Line: 940 Function: fn_seo_check_dispatch File: app/functions/fn.init.php Line: 973 Function: fn_init File: init.php Line: 131 Function: fn_init File: index.php Line: 24 Function: require

------------------------------------------------------------------------



Here is the contents of .htaccess


```php

DirectoryIndex index.html index.php





AddEncoding gzip .gz

RewriteCond %{REQUEST_FILENAME} .(js|css)$

RewriteCond %{HTTP:Accept-encoding} gzip

RewriteCond %{REQUEST_FILENAME}.gz -f

RewriteRule ^(.)$ $1.gz [QSA,L]



.css.gz$>



Header unset ETag

FileETag None

ExpiresActive On

ExpiresDefault “access plus 1 year”



ForceType text/css

Header set Content-Encoding: gzip

Header set Cache-control: private



.js.gz$>



Header unset ETag

FileETag None

ExpiresActive On

ExpiresDefault “access plus 1 year”





ForceType text/javascript

Header set Content-Encoding: gzip

Header set Cache-control: private





Header set Access-Control-Allow-Origin "
"







RewriteEngine on

Please note that RewriteBase setting is obsolete use it only in case you experience some problems with SEO addon.

Some hostings require RewriteBase to be uncommented

Example:

Your store url is http://www.yourcompany.com/store/cart

So “RewriteBase” should be:

RewriteBase /store/cart

RewriteBase /

Options -MultiViews

RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

RewriteCond %{REQUEST_URI} ^api/(.)$ [or]

RewriteCond %{REQUEST_URI} .
/api/(.)$

RewriteCond %{REQUEST_FILENAME} !-f

RewriteCond %{REQUEST_FILENAME} !-d

RewriteRule .api/(.)$ api.php?_d=$1&ajax_custom=1 [L,QSA]

RewriteCond %{REQUEST_URI} .(png|gif|ico|swf|jpe?g|js|css|ttf|svg|eot|woff|yml|xml)$ [or]

RewriteCond %{REQUEST_URI} store_closed.html$

RewriteCond %{REQUEST_FILENAME} !-f

RewriteCond %{REQUEST_FILENAME} !-d

RewriteRule ^(.
?)/(.*)$ $2 [L]

RewriteCond %{REQUEST_FILENAME} !-f

RewriteCond %{REQUEST_FILENAME} !-d

RewriteRule . index.php [L,QSA]



```



Any help appreciated.

Use phpMyAdmin and run the following query:



ALTER TABLE cscart_seo_names ADD `path` varchar(255) NOT NULL DEFAULT '';




I am not sure why this column was missed

[quote name='eComLabs' timestamp='1418636940' post='199759']

Use phpMyAdmin and run the following query:



ALTER TABLE cscart_seo_names ADD `path` varchar(255) NOT NULL DEFAULT '';




I am not sure why this column was missed

[/quote]



That may have actually been the issue, I contacted support to help fix the issue and they simply reinstalled the plugin and fixed it, Which didn't cross my mind at the time. would've saved myself 20 credits. Lol