Profile Field Name Showing In Packing Slip Print


I have added an additional field into my shipping and billing profiles, “Company Name”

When printing packing slips there is a line which pulls in the additional fields

{/if} {include file=“profiles/profiles_extra_fields.tpl” fields=$profile_fields.S}

The issue I am having is that it is that on the printed packing slip it is the names of the field that is being displayed “Company Name”

And not the Value of the field which should be the name of the company.

I would also hope that if this field were left blank as it is not required that it should display nothing.



Can anyone help me to stop the extra profile fields names from showing on the packing slips.

They are pulled from the file. profiles_extra_fields.tpl which contains the below code.

I still want the field values that are filled in in the customer profile to show just not the field name.


{foreach from=$fields item=“field”}

{if !$field.field_name}

{assign var=“value” value=$order_info.fields[$field.field_id]}

{if "AOL"|strpos:$field.field_type !== false} {* Titles/States/Countries *}
{assign var="title" value="`$field.field_id`_descr"}
{elseif $field.field_type == "C"} {* Checkbox *}
{if $value == "Y"}{__("yes")}{else}{__("no")}{/if}
{elseif $field.field_type == "D"} {* Date *}
{elseif "RS"|strpos:$field.field_type !== false} {* Selectbox/Radio *}
{else} {* input/textarea *}



I have the same issue!!



Is there data in those fields i the order? I.e. do you have the “required” checkbox selected for checkout? If not, then maybe there is no value for that field in the order you are looking at.

In my case there is data. And the data shows. But the problem is that als the name of the extra porfile field( in my case “house numer extra”) is also showing. In al light grey colour at the botom of the adress in the order overview and also on the packing list.

You could probably address this in the template profiles/profiles_extra_fields.tpl by making the paragraph tag dependent on the field having a value that is not “”.