problems with locations when copying complete site to different computer

Hi all,

Ok, i have a strange problem.

I have site installed on my localhost (xampp) in windows 7 (work computer).

When i copied the whole site to my private computer (linux Ubuntu 12.04) with lampp installed i noticed that some locations are not working properly, especially the ones I created for custom pages.

For example.

I created a location to display new items and popular items. Now this shows ok when opening page in win (xampp). But when I opened same page in linux, i see items from a different “location”.

Please note i have changed config.local as everything else works as it should.

I tried reinstalling, clear cache, etc, yet still same problem.

Im really not sure why this is happening.

Im attaching two pics (win and linux). As you can see, same page shows two different things.




I haven't experienced your problem specifically, but one thing to double check when moving from Windows to Linux is the capitalisation of your block names, table names etc.

I once had a mysql db merge onto my production server with a mix of “ss_tablename” and “SS_tablename” - as the Linux box saw that as two different names.

Just an example, but it might be something related to capitalisation.


I tried that, it didn’t work, but i managed to fix it by completely delete the site (including the database) and did a fresh install and importing all the stuff. Now it’s working :)

After uploading a live database to my localhost page and importing locations the problem is here again!

I have opened a support ticket but if anyone would know the solution I would appreciated it

here's what is happening:


I downloaded the database from the live site and imported it to my localhost site. Then I imported the locations to see how everything looks on my localhost before I would change the skin on the live site.

All the pages (categories, products) display ok, except for the custom pages (under website > content).

For some reason these pages all point to the one location (in my case “new products”).


I have opened each page i have created in admin and noticed that under the “block” tab they all point to the “new product” page.

This is really strange.

Anyone knows why this is happening?


Hi @UrKo,

Please PM the link and i will check


well after hours of playing i found a temp. solution.

I exported locations but unchecked all that are made for view in pages (page.views).

Now everything works ok…

But will wait for CS for answer as well on ticket support