Problem With Settings: Company Please Help

I am completely stuck. I did the following:

Went in config.local.php and changed this line $config['admin_index'] = 'admin.php'; to $config['admin_index'] = 'admin3653.php'; than I renamed the admin file admin3653.php

than I went to var/cache and deleted that folder

however, everything seems to work until I get to Settings:Company when I try and save it I get a 404 error.

When I rename it back to admin.php it works so I have no clue why…

I also changed this if this matters:

// Default permissions for newly created files and directories