Permissions Problems

Hi Guys,

I'm running 4.1.2 in a test directory at the moment while I set up the new cart as I slowly make the transition from 3.0.6 to 4.1.2.

The problem I'm having seems to be permission related, for example



If I edit things in the theme editor, i can make changes and save and everything looks ok. the problem though is as soon as I exit the theme editor, the cart goes back to the settings that it had prior to the changes made in the visual editor. But when I go back into the visual editor, and check all the changes I made, they are all there and when i hit save a few times, the new changes are reapplied. But again, when I exit the visual editor, it goes back to how it looked before.



Permissions on folders and files are 755, 777 and 644 but no matter what I try, I seem to have lots of these kind of issues.



I emailed cs for support, but as usual, their ever helpful response (below)

If anyone can help out with suggestions or help it would be much appreciated, Im at my wits end with these permission troubles.



Thank you for your time and patience and sorry for the delay in answering.



I have examined your CS-Cart installation and found out that the issue occurs not only for the background but for the other elements of design. The problem is caused by the inability of CS-Cart to overwrite files in the design/themes/basic directory. I tried to change the value of the @rounded_corners variable to off in the design/themes/basic/styles/data/0.1.less file of your style for testing but failed to do it (please have a look at the screen shot attached). Please contact your server administrator regarding this issue.

If you're running cpanel as you site management admin application and your are running PHP in suPHP mode (most common now days) then your public_html folder should be mode 750 with ownership of [cpanel_user]/nobody (where [cpanel_user] is the name of the cpanel account.



Inside of that, all directories should be mode 755 and owner/group of [cpanel_user]/[cpanel_user].

All files should be mode 664 (or 644 or 640) and owner/group of [cpanel_user]/[cpanel_user]



If you have ssh access, you can accomplish this by:

u=[cpanel_user]; g=[cpanel_user]

cd /home/$u

chmod 750 public_html

chown $u:nobody public_html

cd public_html

find * -type d | xargs chmod 755

find * .htaccess -type f | xargs chmod 644

chown -R $u:$g * .htaccess

ls -l .

Thankyou!!!

Hi!

Even after fixing the permissions with this, I still can't get it to save changes to the themes, and even addons that are trying to update are showing permissions problems!

It's as you guessed, [color=#282828][font=arial, verdana, tahoma, sans-serif]PHP in suPHP mode, the error logs aren't showing any errors, any other ideas? It only started having these problems when I upgraded from 4.0.3 to 4.2.1[/font][/color]

[color=#282828][font=arial, verdana, tahoma, sans-serif]Thanks[/font][/color]

Can only suggest you ensure error_reporting(E_ALL) (see config.local.php).

This might put errors in your error_log file that are being supressed.



You did check the browser console for any javascript errors, right?

[list]

[]tbirnseth, I appreciate all your help and perseverance with this, but it looks as though the problems were not related to the actual permissions at all.

[
]In the original support email from CS-Cart, they told me that it was a permissions problem which is what threw me off finding the correct solution and had me tearing my hair out trying to work out the permission issues and why they weren't working or throwing up errors.

[]So!

[
]If anyone else ever has this problem then here's what really happened…When i did the store upgrade from 4.0.2 to 4.1.2, During the upgrade, for some unknown reason these files were not updated

[*]Ajax.php, Api.php, Database.php, Less.php and Registry.php files which are located in the app/Tygh directory and were the 4.0.3 versions of the files, which caused all the problems i was having.

[/list]

WOW, thanks bytraper…that has solved all my problems…I was about to check myself in to a mental hospital…thanks again