Page not found (404) after fresh install trial Ultimate Edition 3.0.6

Hi, I have been using CS-Cart for over a year now. Have installed on a couple of servers and locally. I now got a VPS from Future Hosting. I did a fresh install, all goes good. After install admin panel works, but can not access main page. Brings error:

404 Error

Oops! We were unable to find what you were looking for.

The page you have requested cannot be found.

Error code: Page Not Found

I saw a couple of posts with exactly the error reported, but none offer a solution.

I checked all requirements for server, and they are fine (safe_mod is disabled, GD library is installed, cURL support is enabled…). PHP Version 5.3.22. MySQL version 5.1.68-cll. Had to disable [color=#000000][font=Arial][size=4]ini_set and phpinfo[/size][/font][/color] functions in PHP configuration.

I also recursively set the correct permissions for all my folders and files as given in installation guide. Confired, they are recursively set.

Tried a fresh insall a couple of times.

Could it be my host name? In my config.local.php I have:

$config['http_host'] = '';

$config['http_path'] = '/~modtro';

When I access my site I enter:

Have been spending hours trying to find the problem. Added some debugging output to CS Cart files, and found it was looking for “skins/basic/customer/views/index/index.tpl”. As far as I know, this should not be the case for the Ultimate edition? I already have an ultimate edition running on a different server (recently also upgraded to 3.0.6), and as far as I know the skin should be in “stores/1/skins/basic”.

The folder it looks in (“skins/basic/customer/views/index/index.tpl”) is empty, which causes a “page not found” error to be returned. As a test, I copied the skin from “var/skins_repository/basic” to “skins/basic”, and it works!

It this a bug in the 3.0.6 CS Cart installation file? I installed it 3 times, and installation was always successfull!

I downloaded the installation file from the “File Area” in my CS Cart user account, details are:

CS-Cart 3.0.6 Ultimate Edition

File Size: 46620 kb

Uploaded: Ilya Makarov

Date: Feb 14, 2013, 17:18

Could there possibly be a bug with this installation file?

Hello djhosken,

Thank you for your message.

I have tried to reproduce this problem on my local server several times and, unfortunately, failed to do that. The problem requires examination on your server. Please contact us via Customer Help Desk and provide temporary access to your server by clicking on the Add record link on the Access information page of your Help Desk account so that we could examine the issue.

Thank you.

Pavel Zyukin

CS-Cart Support team