Thanks for the replies
There will not be any issues if you run PHP version 5.4 instead of 5.3......
Incorrect, we have already tested it and there are at least 2 issues we found, and I expect many others.
There are too many functions depreciated in 5.4 and csc 2.1.4 is using a number depreciated functions.
The contact us form did not work for one thing.
Note that you can specify php version for the software in .htaccess file if you face any problem.
Yes, on many servers this is possible, but we need to move forward with 5.4 or 5.5 native for security reasons.
PHP5.3 is no longer supported and is End Of Life. So even if we were to assign 5.3 to the csc2.1.4 in htaccess, this does not solve the problem.
A professional response as always, thank you.
There are other depreciated function in use as well, such as safe_mode, register_globals, and mysqli_ although I dont think this is used.
And the dropping of sqlite, which again we dont use.
I dont want to be turning off warnings or error reporting, I want the code to be compatible with at least 5.4,
I currently dont have time to reprogram and test the code myself thus will need to hire a professional.
In the long term, we will have our "Multiple suppliers per product" addon translated/created to work with csc v4.x.
But in the medium term we will need to keep using the v2.1.4 store.