Need V2.1.4 Store To Run On Php 5.4

We have a v2.1.4 store with too many core mods to upgrade.

Its currently running PHP v5.3 which is now EOL and considered a security risk.

We need to be able to run this store with PHP 5.4 as this is also the min requirement for other software on the server.

So Ive got a few questions.

Q. Is there a a guide or some online software available to search and suggest the necessary changes in PHP commands/syntax required?

Q2. Is any Guru in cscart willing to quote us the cost of the task to make it work with PHP5.4?

Its a job that needs to be done in a professional and accurate manner as its a live, income generating website....


There will not be any issues if you run PHP version 5.4 instead of 5.3. At least the standard CS-Cart version 2.1.4 works properly under PHP 5.5 and 5.4.

If you have any concerns, you can contact us in HelpDesk ( We will be glad to help you

Note that you can specify php version for the software in .htaccess file if you face any problem.

(!) Your hosting should support this feature

Your biggest issues are going to be deprecation issues like not supporting a return by reference for a class instantiation. I.e.

5.3 allows

$obj =& new class_object;
and 5.4 will issue a warning because it's deprecated and it should be changed to
$obj = new class_object;.

These are just warnings and not failures. However, your error_log will fill with these and you'd probably then miss more important things. Turning off reporting of warnings is NOT advised.

You can do a search of "& new" to catch most. Then I'd just address them as they show themselves. Pretty soon you will have upgraded your site to be 5.4 compliant. Note that if you use the PDF generator, that will be the source of a lot of your warnings since the code base is old and virtually not supported..

Thanks for the replies


There will not be any issues if you run PHP version 5.4 instead of 5.3......

Incorrect, we have already tested it and there are at least 2 issues we found, and I expect many others.

There are too many functions depreciated in 5.4 and csc 2.1.4 is using a number depreciated functions.

The contact us form did not work for one thing.


Note that you can specify php version for the software in .htaccess file if you face any problem.

Yes, on many servers this is possible, but we need to move forward with 5.4 or 5.5 native for security reasons.

PHP5.3 is no longer supported and is End Of Life. So even if we were to assign 5.3 to the csc2.1.4 in htaccess, this does not solve the problem.


A professional response as always, thank you.

There are other depreciated function in use as well, such as safe_mode, register_globals, and mysqli_ although I dont think this is used.

And the dropping of sqlite, which again we dont use.

I dont want to be turning off warnings or error reporting, I want the code to be compatible with at least 5.4,

I currently dont have time to reprogram and test the code myself thus will need to hire a professional.

In the long term, we will have our "Multiple suppliers per product" addon translated/created to work with csc v4.x.

But in the medium term we will need to keep using the v2.1.4 store.

Just a quick reminder about CS-Cart compatibility with different PHP versions

PHP 5.1.x, 5.2.x:

CS-Cart 1.3.x ( PHP 4 is also supported)
CS-Cart 2.0.Ñ…

PHP 5.1.x, 5.2.x, 5.3.x

CS-Cart 2.1.x
CS-Cart 2.2.x
CS-Cart 3.0.x

PHP 5.3.x, 5.4.x, 5.5.x, 5.6.x

CS-Cart 4.x.x

Thanks for the info..

Perhaps since 4.x.x runs on PHP5.6, I think we should aim to re-code our v2.1.4 store to work on PHP5.6 rather than just 5.4.