Live Help... grrr

When I first installed it and tried to test my connection I would get the same error message everyone has reported. I futzed w/ it and finally got it working using simply: [url][/url]

Now all of a sudden it’s not working anymore. I have changed NOTHING. Has anyone figured out exactly what that error message is saying and a found a fix?



I set up a support case and here is what I got back (it’s a couple of messages pasted together):

I said - “I can get the client to connect and then it randomly disconects for no apparent reason. I have not been able to be connected for more than a minute before being disconected or getting an error. I also get the following error:

Error Identifier: 67127

Time: Mon Apr 16 10:19:26 2007

Type: exceptions.TypeError

Value: unsubscriptable object

Session information


app_version: 1.0b

platform: WXMSW, wxMSW, unicode, wx-assertions-on, SWIG-1.3.29

And when I check the log I have the following entry:

C:\Program Files\\LiveHelp\resources.dat\ DeprecationWarning: The wxPython compatibility package is no longer automatically generated or activly maintained. Please switch to the wx package as soon as possible.”

They replied - “There’re compatibility issues of LiveHelp client with some operating systems/operating system settings. The LiveHelp software will be rewritten completely in the next CS-Cart version. As for the current version, unfortunatelly it is not operational on your system.”

I asked - “Would it be possible to get the requirements of a system known to work with the current version of the LiveHelp client? I’d like to set a system up so I can offer this to my customers.”

They replied - “LiveHelp is in beta status now and I wouldn’t advise you to offer it to your clients.

As for system requirements - we didn’t find the specific systems, where LiveHelp is not operational. For example, it works on our WinXPs (we tested on ~20 computers), and it works on our one client’s WinXP, but it doesn’t work on our other client’s WinXP.

Hope this makes sense.”

So that’s what I know.

I have live help running in my store, could you be more specific as to the problem? you say its not working, you mean its not connecting on the client side? or is it not appearing on your website or is it not working on your website?

It was working and now it’s not. I haven’t changed anything. The site side seems fine, but when I go into configure and then 'test connection" I get:

Connection test failed.

Server has returned text (copied to Clipboard);

Request: lh_operator&test=1, params:


But nothing gets copied to the clipboard


I suppose the key point to rember is Live help is a beta version, being their first release of the live help module they are bound to experience numerous issues.

Initially I had all the same problems as above, therefore Im not intending on using it until their stable release, Theres millions of possible configurations and the best way to get it sorted is to let them know specifics.

Machine Config, Server Info and of course problems encountered.

Hope this can help.

I had Live Help working until yesterday night when I installed a recently livehelp version from the file are in customer support. Previosly I had a file dated on April and it was working just fine, except for the off line message that I could not know where to check these messages.

I’m having the same situation over on my end as well. I just enabled it on my site but the application gives me the same Connection test failed message.

If you have a LIVE shop, don’t ever use a beta extension/module for it. Beta is for testing, not for production.

If I really have to use something that’s not stable, it has to be at least a Release Candidate (RC).



I had the same issues then you. I contact Helpdesk opening a ticket and they fixed the remanining issues in a day. Live Help is working since than.

Give it a try


mine is not working at all even on store i dont get image of live ehlp appear and when i click begin chat nothing happen so i dont bother even to install app for this

I wish this software came with a step-by-step manual.

I can’t even get past the whole path to store part.