Import product Fatal error in v2.13

I am running into issues trying to load a large database (200,00 plus products!).

I’ve increased the memory in config.local.php to 512M. I’ve broken down the CSV file to 50,000 product increments. And, I get what appears to be a time-out error…

Fatal error: Maximum execution time of 3600 seconds exceeded in C:\xampp\htdocs\cscart\core\db\mysqli.php on line 71.

It is not readily evident to me what needs to change in this file. Why does it use mysqli.php over mysql.php?

Thanks in advance for your assistance.

Because that’s what it read your configuration as. You can change it in config.local.php

```php // Set maximum time limit for script execution



  • Database connection options


    $config[‘db_host’] = ‘%DB_HOST%’;

    $config[‘db_name’] = ‘%DB_NAME%’;

    $config[‘db_user’] = ‘%DB_USER%’;

    $config[‘db_password’] = ‘%DB_PASSWORD%’;

    $config[‘db_type’] = ‘[COLOR=“Red”]mysql[/COLOR]’; ```

    Also, I don’t know how big your files are that you are importing but the max is usually about 8MB. Alternatively it may be taking too long if your files are too large.