Images Not Loading On Import

I'm running 4.1.2 on a fresh installation of CS-Cart. I have my images and thumbnails in the folder /var/exim/backup/images/. When I do Import Data → Products, then select my local file, tab delimited, none of my product images or thumbnails appear.



Example: I can access them directly with no problem.



[url=“http://50.62.78.221/var/exim/backup/images/50630.jpg”]http://50.62.78.221/...mages/50630.jpg[/url]



However the corresponding product has no image or thumbnail.



[url=“http://50.62.78.221/standard/theros-block/theros/sealock-monster.html”]http://50.62.78.221/...ck-monster.html[/url]







My import data is the following (by example).



Set name Number Product code Language Category List price Price Status Quantity Weight Min Quantity Shipping freight Downloadable Ship downloadable Inventory tracking Out of stock actions Free shipping Feature comparison Zero price action Thumbnail Detailed image Product name Description Short description Meta keywords Meta description Search words Page title Features Secondary categories Store

THS 62 50630 en Standard///Theros Block///Theros 0.03 0.03 A 0 0 0 0 N N B S Y N R 50630-thumb.jpg 50630.jpg Sealock Monster Purchase Sealock Monster from the Theros set at Cardhoarder. Buy millions of MTGO cards, tickets, foils, including Theros and more. Sealock Monster MTGO Cardhoarder, Magic the Gathering Online Card - Sealock Monster [THS] Version: S[Normal]; Cardhoarder





I looked at my error_log file and I have a bunch of these statements:



[Tue Feb 04 13:29:43 2014] [warn] [client 68.4.133.21] mod_fcgid: stderr: PHP Warning: reset() expects parameter 1 to be array, null given in /var/www/vhosts/cardhoarder.com/httpdocs/app/schemas/exim/products.functions.php on line 468, referer: http://50.62.78.221/admin.php?dispatch=exim.import§ion=products



Don't know if there's any relevance to this problem or not.





Tweaker

Anybody from support still use these forums?



Tweaker

Issues like this will likely require investigating by CS-Cart therefore you should submit a support ticket. CS will require access/login details, etc, to identify and provide a solution to the problem.

Thanks, if that's what CS-Cart forum support needs me to do then I can certainly do that. Support?



Tweaker

[quote name='tweaker' timestamp='1391623794' post='176867']

Thanks, if that's what CS-Cart forum support needs me to do then I can certainly do that. Support?



Tweaker

[/quote]



Hi, did you solved this I have the same problem in 4.1.4, no images when import, but they exist in images/detailed/*

I am having the same exact problem…any help from Admin??

i'm on 4.1.4 and my images I loads to /public_html/var/files/1/exim/backup/images/ That is the default as I know it not as some have put /var/exim/backup/images/ so make sure that is correct (wrong directory it wont work).

Make sure the image filenames and csv files names are exact this include upper and lower case for filename and extension.

If you have imported the product csv already you will need to re upload the csv and tick the “Delete all existing product files before import:” . Uploading the images to the right directory wont be enough to have it working, you will need to do exactly as I've put.



Hope this helps

I am having this same problem ever since I upgraded past 4.0.3. IT's very frustrating. I have submitted help tickets but so far no useful help with the issue.



I used to be able to specify any image path that I wanted and it would work. Now I have tried many different things, but no matter what path I specify in a CSV import, it will not change the path to what I specify. So after trying too many times I finally moved all of my images into the folder where it seems to think they are [color=#282828][font=arial, verdana, tahoma, sans-serif]/public_html/“my directory” /var/files/1/exim/backup/images/ but it makes no difference, the images are there but do not display on my store or admin. I can manually upload individual images and it works as it should, but that is not practical when dealing with over 8000 product images. [/font][/color]



I notice that now it is treating my CSV imports as file uploads and the CSV's I import are showing up in the file editor as if I meant to upload a text file. Strange behavior an very time consuming to try to fix. I am going to attempt the above posters method and hope it works while I await a helpful response to my ticket.

I was finally able to resolve this issue myself. The CSV import feature is clearly broken in this version, or maybe it's just a problem on my server, but it used to work fine before I upgraded from 4.0.3.



I was only able to get my images to load by moving copies of them all into the directory specified under DETAILED IMAGE URL. No amount of importing CSV data will make any difference in changing the directory where CS-cart thinks they should be., which is still a huge problem that support cannot seem to address properly when I ask for a solution.



I had the same problem with my thumbnails, and also solved it in the same way.



The whole var/files… path doesn't work at all. I have all of my images in that directory and even though CS-cart says that;;s where they should be it somehow does not see them, so once again, DETAILED IMAGE URL and THUMBNAIL are the directories that worked for me. Clearing thumbs via the two usual methods did nothing.



Hopefully this info can save someone else some headaches.

Please let me know what path you used to import the images and also did the images should be again in subfolders /product & /detailed or directly in the folder (i tried both ways anyway)

I tried this folders:

/web/var/files/1/exim/backup/images/

/web/exim/backup/images/

/web/images/backup

currently the lines in the csv looks like:

“01505501”;“M”;“/web/var/files/1/exim/backup/images/product/015001.jpg#{[BG]:;[EL]:;[EN]:;}”;“/web/var/files/1/exim/backup/images/detailed/01505501.jpg#{[BG]:;[EL]:;}”



And I have the files uploaded via ftp, but after the import no pictures shows on the site!

I have the same problem. Despite paying a lot of money for multivendor ultimate, now that i have not support time, they dont give any answer.

So sad about losing my money buying this system. It was a big mistake. They should have support for things like this. If you find a bug and you have not support you have no help from nobody.

When i had the support time active, they also dont use to solve the most of the problems.

I made a bad election of system, i should have checked support conditions before expending such a big amoun of money.