Hybrid Auth - Error: Redirect_Uri_Mismatch


I have setup my Hybrid Auth addon for “Login via Google” but if we try to authenticate we are getting an Error[font=arial, sans-serif][size=4]

Error: redirect_uri_mismatch[/size][/font][font=arial, sans-serif][size=4]

Application: FleAffair[/size][/font][font=arial, sans-serif][size=4]

You can email the developer of this application at:XXXXXXX@gmail.com[/size][/font][font=arial, sans-serif][size=4]

The redirect URI in the request: https://www.fleaffair.com/index.php?dispatch=auth.process&hauth.done=Google4 did not match a registered redirect URI.[/size][/font][font=arial, sans-serif][size=4]

Learn more[/size][/font]Request Details




[]scope=https://www.googleapis.com/auth/userinfo.profile https://www.googleapis.com/auth/userinfo.email https://www.google.com/m8/feeds/








[/list][font=arial, sans-serif][size=4]

That’s all we know.[/size][/font]

Kindly help me know what is wrong with my Google Hybrid Auth.

you need to update you cs cart…to 4.2.3

[quote name='demeldoo' timestamp='1414873284' post='195895']

you need to update you cs cart…to 4.2.3


Is there no other way to get this fixed?

[quote name='fleaffair' timestamp='1414876456' post='195898']

Is there no other way to get this fixed?


You can get the patch from cs-cart helpdesk.

[quote name='cscartrocks' timestamp='1414886788' post='195902']

You can get the patch from cs-cart helpdesk.


As per CS-cart there is no issue with there add on. There are saying that callback URI setting must be wrong. I am not getting proper documentation to set it correct. Can anyone help me on this issue.

Do you have 4.2.3 running?

[quote name='demeldoo' timestamp='1415702789' post='196615']

Do you have 4.2.3 running?


No, we are working on 4.1.5 version

I'm getting the same error on MV 4.2.4. Does something need updated?

Please check our answer in another thread

Maybe this will help. I've been smashing my head to walls till I found why GOOGLE login WAS NOT working meanwhile Facebook and LinkedIn worked like a charm!

[color=#3F4549][font=Georgia, Times, serif][size=4][left]If you get “User profile request failed! Google returned an invalid response” you need to enable Google+ and Contacts API in your APIs google console.[/left][/size][/font][/color]

If you get a [font=arial, sans-serif][size=4]“Error: redirect_uri_mismatch” you need to update in your Google API Console the following: [/size][/font]

[font=arial, sans-serif][size=4]http://yourdomain_name/index.php?dispatch=auth.process&hauth.done=google[/size][/font]

After that, update your website IP inside the Key Server App (edit allowed IP's).

Hopefully, this will help.

I've been searching for more than 4 days to make this woirking. Now, everything looks and works like a charm!

Furthermore: the more possibilities you add to your credentials client ID, the more ways to get this working you'll get.











[size=4]And, of course, secure protocol if necessary (HTTPS). [/size][/size][/font]


[size=4]Last: you need to use your credential data (client ID and your client secret key)! DO NOT USE API Key! [/size][/size][/font]

THANK YOU! Works fine now for me as well. :)

i am getting Error : Unspecified Error By Applying Above Solution

I am also getting Error : Unspecified Error

Please Help :-(