How To Prevent From Sending Email When An Order Placed?

I use the code below to save orders remotely in my addon :


list($order_id, $process_payment) = fn_place_order($cart, $auth, 'save')




How to prevent from sending email to the customer when an order placed remotely?



Note: I don't want to change default settings of OPEN status.

The solution is more simple ;)


  1. Please go to Administration > Order Statuses




  2. Edit Open status and uncheck Notify customer





    [color=#008000]PS: If this helps you please Vote this post ;)[/color]



    Regards,





    Valentin

    [color=#808080][size=2]part of hungryweb.net[/size][/color]

Use the get_notification_rules hook in the fn_get_notification_rules function (app/functions/fn.common.php)

Thanks to all.

What happen to Notify Customer and Notify Order Department. I no longer see then in

4.4.2.SP2

Thanks

Mark

Hi

I made same mistake, if you have email editor active they don't show and you manage in the editor.

Barry

OK I have disabled

Order notification: Default template for a new order status

and

Order notification: Open
I still get an email for open and paid, All I want is paid. I cannot seem to find the answer

go into the order status "open" and remove the check box that says email

OK I have disabled
Order notification: Default template for a new order status[/url]
and
Order notification: Open[/url]

I still get an email for open and paid, All I want is paid. I cannot seem to find the answer



I would also advise removing the links in your post.

OK I have disabled

Order notification: Default template for a new order status

and

Order notification: Open
I still get an email for open and paid, All I want is paid. I cannot seem to find the answer

It looks like a bug. Please post it to the bug tracker