How I Can Hide / Disable This Fields And Tab In Vendor Account?

how i can hide/disable :
1. Extra Menu in vendor user panel (add product)
2. Options setting
3. Pricing / inventory for all fields. (except CODE & In Stock + Min Order quantity)
4. Availability

Quantity discounts tab
Facebook Object type


im using multivendor latest version

Control menu content you can with the permissions schema


As for other changes, just find corresponding templates in the design/backend directory and add the following condition to the required field:

{if !$runtime.company_id}
    ... this text is for store admins only....

We’ve developed an easy to use addon tha allows you to hide selected menus, tabs and fields from Vendors.

It can also optionally modify email fields for:
+ From customer to Vendor - hide customer email/phone fields, change from/reply-to email headers to be from site
+ From Vendor to Customer - change From/Reply-to to Site email address (TBD - change Vendor’s email/phone to site’s email/phone).

Purchase site:
Documentation: https;//

Hi guys,

thanks to the above addon I was able to modify most of the fields in the vendor panel without too much effort.

One thing is still missing though. Hope you can help:

On the products.manage page I have a submenu that appears once multiple products are selected. I want do disable it.

Also I want to disable "list_price" and "amount" columns as there are already disabled in products.add

Any Ideas how to solve this?



Will take a while to investigate and see if this is something we want to add. Did you want to hide the whole menu of selection options? Note that the gear-icon also duplicates some of these options. Note that these tabs are only on the newest versions of cs-cart.

hiding the columns in the listing may not be possible (or reasonable) if there are not hooks specifically around those fields. A hook for the row will only mean that sometime in the future, cs-cart's gonna add a column or change something that wouldn't then be availble. It opens a maintenance nightmare that we're not staffed to follow.

The menu can be hidden by using a hook. We'll add this in a future update.

However, the columns on the manage page we are not able to support given we have no intention of verifying/updating this addon at every future release of cs-cart.

We've updated the ability to allow you to hide the Bulk Edit Menu displayed on the products.manage page when a product is selected.

It is listed under the "Fields" tab, not the "Menus" tab. It is not actually a menu but a chunk of hooked html code. To handle it correctly we had to put it with other fields that use hooks to enable/disable functionality.

The new version is 4.12.6. Your site should upgrade automatically (like all our addons) in the next day or so. But if you want to get it now, you can use


Which will force an upgrade to the current version.

Hi Tony,

thanks for the update. Will install accordingly.

For the columns:

As I need the columns to be disabled (only single products are uploaded, no list price needed), where do I have to do the changes?

I understand that it does not make sense for you without a hook. But in my case I will just change the array / comment out the part and follow up on it once I update cs-cart.




Search for 'list'

thanks. that worked...

since I disabled many permissions, the menu in the vendor panel consists only of a few items which I would like to sort differently.

For instance I do not need the Menu header "Product" doubled withe Menu item "Product".

Therefore I would like to bring the second product to the header level.

Could you please explain me where I can find the code to change the vendor menu items?



Changing menu structure is well outside the scope of the community forum.

Personally, I prefer UI's that work as follows for a main menu:

* hover displays the list after 500ms

* clicking the menu name (top) automatically selects the first item in the list which should (in this case) be 'Products'

It saves clicks and (like you've noted) saves \duplication especially on mobile devices. It also seems much more intuitive than a Products menu where Categories is the first in the list. But that can be changed in the backend. But the main navigation menu functionality is pretty embedded in the code. You could add a lang variable and call it something like product_menu_item and give it a value of "Seller info" and then change the schema for the navigation to use that language variable in a my_changes/schemas/menu/

You can change vendor menu by extending the following schema


hello ,

are you guys saying you can somehow change the menu around ?

Jerritt: You can change the name of menu items , ( but the same change will also reflect in your own admin ) also you can hide some items

in customers (vendors panel ) i have had removed everything but 'message' so now on vendor side it looks like customers >message .

I would have changed 'customers to simply 'message , but on my admin side it would have reflected similarly and that doesnt make sense on my dashboard.

I have tried to have items moved around , but thats something that cs cart would not do . As tbirnseth said the main navigation seems pretty embedded in the code .

please let me know what sort of change can be done on the menu with app/shemas/menu/menu_multivendor.php please and would it survive upgrade ?

I just want to reorganise menu items around.

Thank you very much

your request is well beyond the scope of a community forum. Suffice to say that yes, you can change things to appear differently in the admin/vendor views. But you would need to either override the pages to change language variable names based on context or ask cs-cart to add a hook (or temporarily add one yourself) to the __() function like

fn_set_hook('lang_vars_pre', $var, $params, $lang_code)

that would allow you to change the value of a language variable if a comparable name existed. I.e. for


if an complementary name of 'vendor.customers' exists, then you would substitute that value for $var.

This is all just examples, don't rely on the actual values I've referenced. A better (more unique) naming construct would be better.

Thank you very much for your reply