Hi All

I have a product that i ONLY have 2 of.

I have added it and said when zero price do not add product,

However i can enter 4 products then add to cart and i can complete the order.

How can i make sure it dont sell More then the 2 i have ?

Enable stock control.

You have a couple of options:

  1. Uncheck “Allow negative amount in inventory” in the General tab of Administration settings.This will be a universal setting for all products;
  2. For specific products, set the following in Catalog->Products:

    Quantity step: 1

    List quantity count: 2

    This will present a dropdown on the product with options for only 1 or 2 items.

    You could also just set the “Maximum order quantity” to 2 which will adjust the quantity to the maximum if the customer orders more. However, I do not think the notification is prominent enough and the customer may miss the adjustment and wonder what is going on.


I Use 1.3.5 and the last sp

Then your only option will be to uncheck “Allow negative amount in inventory”.


another option is to upgrade…