Google indexed pages for langauge not active - Not found (404)

I have a cs cart website which has 2 languages.
My default language is not english is spanish
English language was not active, was either hidden or inactive.

I received some messages from google that some pages for english language were Not found (404) eg. - content in my default langauge - content in english language

  1. How can Avoid content in english to indexed by google?
  2. How can I fix pages with Not found (404) should I do redirect or is a way to remove from google indexing?

Thank you!

Please make sure that the sitemap.xml file is generated dynamically and does not exist in the root directory of your CS-Cart installation. If it is there, delete the file

Also do not forget to regenerate the sitemap from the Google Sitemap addon settings

1 Like