Google Checkout

I had a customer asking for Google Checkout. So I am trying to get this setup.

I have a problem…Under Admin / Payment Methods if you set up Google Checkout the Cart specifies an http address for the site then when you go to Google Checkout to enter this address you get an error. Requires an https address. Does anyone know what to do to resolve this?

Also…I finally got my SSL Certificate installed yesterday and most of the weird issues I was trying to deal with (with the help of everyone in the forum) seems to have just dissapeared. Very strange but, I am grateful anyway.:stuck_out_tongue:

if i understand your question correctly, just pick

‘https’ from the select box on

Home—> Payment methods

under protocol

[quote name=‘MikeFold’]if i understand your question correctly, just pick

‘https’ from the select box on

Home—> Payment methods

under protocol[/QUOTE]

Hi Mike,

I selected Processor Google Checkout, Protocol is https, Template is cc_outside.tpl then when I click on configure I get Please set the “Api callback URL” parameter at merchant center to [B][url][/url][/B]I’ve tried several times now and that http part does not change. Did I miss something?

sorry…i have not setup google checkout…

i tried a quick search for ya, and found nothing directly related to setup.

I know some threads exist, but, since I don’t use it, I can’t assist any further…

Thanks Mike. I appreciate your help.

Mine was like that when using 1.3.4 sp2 but with 1.3.5 it stays https.

Though, it works fine before, I was able to process transactions without any hitups in 1.3.4 google checkout.

I found the problem and was able to fix it! For some reason when https was picked it was not actually changing in the google_checkout.tpl. I had to edit the google_checkout.tpl. I just added the “s” to http in line #2. This is the original line:

{assign var=“r_url” value=“$http_location/payments/cc_processors/google_checkout_response.php”} This is the corrected line:

{assign var=“r_url” value=“$https_location/payments/cc_processors/google_checkout_response.php”}

This is the Call Back URL that displays when you add Google Checkout under Payment Methods. I saved this change. I then copied and pasted this statement into the Google Checkout setup section in Google and went back to the site and it worked fine.

It seems like I am always asking for help so it feels good to have provided the forum with a solution. I hope this helps others.

I’m proud of ya Sherry