Googe Products Feed Image Issues

Is anyone having problems with the images not appearing in the Google Products feed results using the Google feed export? Google told us to unblock the images from the robots text file which we did, but they are still not appearing after resubmitting several times and weeks have gone by. Using version 3.0.3

Hello keith,

Thank you for your message.

I am sorry to hear that you have experienced this issue. The problem requires the examination on your server. Please contact us via Customer Help Desk and provide temporary access to your server by clicking on the Add record link on the Access information page of your Help Desk account so that we could examine the issue.

Thank you.

Pavel Zyukin

CS-Cart Support team

Same problem here as Keith… no images are blocked in robots, I can call the url up in a browser, and product feed gets submitted without any issues. I have even been able to converse with a human at Google, they see no reason why they can't access images either.

Is there a fix?

I also found a similar issue when trying to optimise a 3.0.4 CS-Cart site, various product images shown on homepage blocks (featured and newest product types) would not take advantage of browser caching, despite .htaccess rules - which do work on a plain XHTML/CSS site on the same hosting environment with the same .htaccess rules - I still have no idea why. The file path in the document source is correct, there are no limitations on robots.txt or further .htaccess rules within the /images/ directory or subdirectories.

I'm assuming this is probably all related, as I do not have the same problem in a 2.2.5 store on the same server.

Update… I have issued a ticket with CS and they want to take a peak at our server. If they find anything I'll report back.

I also notice that any new products I add to our cart get listed eventually on google (after I resubmit our feed). The only products staying disapproved are the products that google says has their images blocked by robots (which they're not). So, methinks it's not a CS issue, as new products do get listed.

Google has been good at getting back to me, but I have not heard from them in the last 24. Will report back…

Stellar - this has not happened to us before, only noticed this in the last month. I have incrementally updated to 2.2.5 recently, but it wasn't happening before for us. ?

One last update… our products are now listing. Applause! I am not sure what changed overnight (as of this morning, CS and Google were still looking into it, but I'll call off those dogs). [EDIT : CS has since confirmed they did not change anything on our server or within our code.]

Anyway, the one thing I tried yesterday was changing my thumbnail size in CS. This creates a new directory and a new image link in the export. I resubmitted the feed, and I believe that somehow did the trick by resetting/overwriting whatever old data Google had messing things up. Not sure if going back to original thumbnail size would be ok, but not going to try now as things seem to be working.

I'll try to report back, but as of now, we're happy again. Hope this helps.

I have a similar problem, it says that 3800+ images are roboted (which they aren't) while over 6000 are showing up just fine. Really aggravating.

Having the same problem, tried changing thumb sizes to no avail. I have tracked the folder down that is giving the problems /images/thumbnails/ 13/

Everything under /13/ doesn't pull in merchant … anyone have a solution?