Email Notifications Suddenly Stopped - Nothing Changed

All of a sudden, email notifications have stopped sending. Nothing changed. Last week I did upgrade to 4.18.1, but I’ve received email notifications since than, so presumably that is not the cause. I’ve checked my smtp settings, and everything seems to be in order. Can anyone think of anything else that would cause this?

I have my host looking into this, but so far no solutions. Here is the error message I get when the system tries to send any kind of email:

ErrorMessage could not be sent.
Mailer Error: SMTP connect() failed. Troubleshooting · PHPMailer/PHPMailer Wiki · GitHub

So my hosting company (InMotion) got back to me and said the only way this can work, as far as they are concerned, is to remove authentication. The problem is, when I placed a test order, the email that came to my personal Gmail address had a message from Google saying: Be careful with this message. The sender hasn’t authenticated this message so Gmail can’t verify that it actually came from them.
Does anyone have any input on this please?

Hi Kingsley, I feel your pain when it comes to “this isn’t working now and I haven’t changed anything.” Been there. But we all know that something must have changed because it was working. And in my experience (which has been too many times) it is always the host moving sites, moving servers, a cPanel or back end upgrade, a PHP upgrade, an extension no longer installed or configured wrong, etc. something out of your control or done without your knowledge.

I’m sorry I’m not technically capable of helping, but I would press the host again to see what could have happened. An upgrade bug in 4.18.1 would likely have other users like yourself stating the same problem suddenly, and running without authentication doesn’t seem to be a solution, at least not for the customer’s end experience.

Keep us posted what you find out.

@wwgreen Thanks. I guess you are probably right that something must have changed on the host. I guess I will have to hop on their support chat again and see if a different rep can help. The guy who was working on it said that whenever he turned on authentication, he got this error:

2024-05-20 07:38:40 SMTP call from [209.182.205.42]:44942 dropped: too many syntax or protocol errors (last command was “?\035?\027?\036?\031?\030?#???\026???\027???\r?0?.\004\003\005\003\006\003\b\007\b\b\b \b”, NULL)

Any progress or change?

Unfortunately not. I haven’t had time to pursue it with the host yet. I work a full time job and we are crazy busy right now, so the Kingsley Press stuff is all in my spare time. Which is why I hate it when something just randomly goes wrong with the site that has been working just fine literally for years on end. I will definitely update here when something changes…or even if it doesn’t.

Have you tried changing to pHP mail function for now

When I change the dropdown from “via SMTP server” to “via php mail function” and then click “Save”, I get this error message:
SMTP ErrorFailed to connect to server: (0)
–this is with "Use Encrypted Connection set to SSL and authentication checked…if I turn off encryption and authentication, it works OK (just as it does with the SMTP server option with these turned off), but I’m trying to get away from sending non-authenticated emails.