Email Marketing Links-Strange Behaviou with CS-CART


I use Verticalresponse for email marketing. I have test emails [and tried the one I sent last week]

When I click a link to a product, there is some very strange behaviour. On my wifes computer, with vista and IE8 she gets the message: HTTP 406 Not Acceptable. Inernet Explorer cannot read this webpage format.

When I click on a link using Windows 7 and IE8 or Firfox, latest version, I sometimes do not see the product image, the page gets messed up, ie all links go down left site of page and no images, and more recently, The page loads OK, but any of the dropdowns, when selecting different choices I get the message: Error

Oops, something goes wrong (error). Please try again.

I now get this for any product that I go to on the site.

When I close the browser and go directly to the site, both on my wifes computer and mine, I don’t see any of these anomolies.

Has anyone ever heard of this.?

Evidently, the site does work. Someone just purchased and item now, and used the option dropdown with no problem.



What do the browser error console(s) say? It sounds like you’re getting a js error.

Well, I can find out if you tell be where the browser error consoles are?

I am assuming its a JS error.

I am on the site now. No problem after shutting down browser and clearing browser cache.

I have repeated this on two computers.

Just did it again, clicked on link on email and now get the OOPS message.

I am going to contact verticalresponse. I need some one else to try it.



I’m trying to remember where I’ve seen the oops message before in the cart code. I thought it was the registry but can’t seem to find it. If I recall correctly it was trying to get a registry value that should have been set but wasn’t. Not much help I know…

In FF, the error console is available under the Tools menu. In IE, it usually just spits them out as popup messages asking if you want to debug (but I think it depends upon the IE settings).


I had someone click on the link in the email. The page opened and then the entire site was not accessible. When I do it, I get unformatted pages or other anomalies.

It has to be the url link. See below for what it looks like, I just changed our site name, but will give you an idea. Would this link cause problems. I tried, and it took to to the product page, it looks good, but when selecting an option I get the OOPs message. Also, if I am in the admin at the time I use the link, then click on anything in the admin, I am redirected to the home page with a ?sef_rewrite=1.

I have to clear the browser cache to get back into the admin.

When the url in the email is clicked, the url on the address bar on the website looks like this:


I will be initiating a ticket with cs-cart and Vertical Response. Just wanted to know if anyone else had this problem. Don’t want to “reinvent the wheel”, If I don’t have to.




After having 4 people confirm the problem. I initiated a ticket with Secure Cart Hosting. They located and fixed the problem within 45 minutes.

The problem was a combination of Intrusion detection on the server and the syntax/structure of the url from Vertical Response. The Intrusion detection was working as designed (cs-cart term). Am working with Vertical Response on corrective action for their URL.