Customers have been telling us they can't add things to their cart 2.2.4

Well, I’ve tried to search the forum and CS via Google, but I just cannot seem to find anything on this. If it is a repeat, sorry.

We’ve started asking more questions when customers are calling us or talking via live help trying to figure out if they are having issues with the site. Beyond people just saying they put stuff in their cart and for some reason it just empties itself, they are telling us that when they click the “add to cart” button it looks like it is doing something, but it doesn’t add anything to their cart. So basically, they cannot shop on our site because it will not add anything to their cart. We are happy when they call us so we can take their order over the phone, but we wonder how many people just leave the site.

At one time I believe I was told that it is better to not use the…

“AJAX(Javascript)-based “add to cart” button”

…in the "Settings >> Dynamic HTML

Is it better to leave this setting off? Is there maybe something else? We do sell to a lot of seniors so many of them have older computers. The customer I just spoke with a few minutes ago said they were using Windows 7, with IE. I couldn’t get her to figure out what version before she became flustered.

did you try to test with those browsers ?

what item they added ? etc etc… try to replicate

I've tested with multiple browsers including IE 7,8, 9, Firefox, Chrome and Opera. Did not have any issues. I also tried to use a Windows XP and I can not duplicate. I ended up just turning off the ajax add to cart. I did notice that one of the customers did get an order to go through this morning, but I'm not for sure if she tried from home again or did it from work.

First thing to do is to clear cache.

Other than that. The trouble shooter will need access to your store

I cleared the cache and manually deleted it in the var folder.

What is the “trouble shooter” that needs access to our store? I'm not for sure what you mean here.

For now we have the “AJAX(Javascript)-based “add to cart” button” turned off and it seems to be working. We will wait to see if another customers gives us the same report.

Hi Clips. I have the same issue. Did you find any more information about it?


Just found out at my store (Ultimate v3.0.x) If I set the “Tell a friend” tab to “on”, the “add to cart button” on a product page does not work.

Maybe you should try to deactivate the tell a friend mode (if is is on) and tr again. Maybe it will do something for you?

Since I upgraded 2.2.5 I don't seem to have the same problem.