Cs Cart Error "service Unavailable" When Clicking Feature Brand/manufacturer On Product Page

Hi, we have two storefronts. On both storefronts, products have Brand/Manufacturer features set to Show in product header on the product page. This results in clickable links, let's say “Sony”. When you click the link, you are taken to a filtered manufacturer listing with all products by “Sony”.



However, this recently only works in one of the storefronts. On the other front it results in a strange animated CS Cart error “Service Unavailable” (see attached).



I have compared the features settings for both storefronts and could not find any differences. Any idea how to fix this?

Capture.JPG

[quote name='japanexp' timestamp='1409037620' post='190647']

Hi, we have two storefronts. On both storefronts, products have Brand/Manufacturer features set to Show in product header on the product page. This results in clickable links, let's say “Sony”. When you click the link, you are taken to a filtered manufacturer listing with all products by “Sony”.



However, this recently only works in one of the storefronts. On the other front it results in a strange animated CS Cart error “Service Unavailable” (see attached).



I have compared the features settings for both storefronts and could not find any differences. Any idea how to fix this?

[/quote]



Uncomment the following line in the config.php file to check error message:



//define('DEVELOPMENT', true);

Hi there, thanks for the tip. Here is the dev/debug message:



Message



[color=#000000]No storefronts defined for this domain[/color]



Error at



[color=#000000]app/functions/fn.init.php, line: 937[/color]



Backtrace

File: init.php

Line: 128

Function: fn_init File: index.php

Line: 24

Function: require

PS: one thing that is different between fronts is that the non-working storefront has two Brand/Manufacturer features, the working one only a single one. Not sure if that makes a difference though.

[quote name='japanexp' timestamp='1409052934' post='190666']

PS: one thing that is different between fronts is that the non-working storefront has two Brand/Manufacturer features, the working one only a single one. Not sure if that makes a difference though.

[/quote]



Do other pages of this store-front work correctly?

Hi, as far as we see it is operating normally without issues. Orders are being placed etc.

[quote name='japanexp' timestamp='1409057290' post='190673']

Hi, as far as we see it is operating normally without issues. Orders are being placed etc.

[/quote]



Additional examination is required. Please address this issue to CS-Cart helpdesk or hire someone from this forum to investigate it. We can also perform this work for you. Thanks

Looks like 4.2.2 update fixed it… thanks!

[quote name='japanexp' timestamp='1409325570' post='191051']

Looks like 4.2.2 update fixed it… thanks!

[/quote]



Thank you for letting us know it