Changed To Php 5.4 In Cpanel But Php Info Still Shows 5.3.29 ?

Hi super brain guys.

I currently have 4.1.4 installed.

'Finally' moved up from 3.0.6

Flushed cache and all but after selecting php 5.4 in cPanel

my Admin > Logs > php info still shows 5.3.29

It's been over an hour now. Is there some time lag when php versions are changed ?


hmm… please try to restart the server (apache or nginx).

best regards,

WSA team

Will ask my web host but it's on a shared server so I am not sure. Still awaiting their reply.

What do you mean you selected php5.4 in cpanel? I am not aware of being able to change php version in cPanel.

Anyway, to change to php5.4, you need to add the following to htaccess:

AddHandler application/x-httpd-php54 .php .php5 .php4 .php3

The Tool,

I was surprised myself when changing hosts, I can change php version in cpanel. I am on a shared server. I have a link: Select php version.

Attached is screen capture.


cpanel-php selection.jpg

Interesting. That must be something new? Very nice addition especially for shared hosting.

May be this option is available in cPanel but it does not work? Try to contact hosting administrator

[font=verdana,geneva,sans-serif]Where did my other post go ( maybe on another thread…lol ).[/font]

[font=verdana,geneva,sans-serif]Turns out that I selected php 5.4 , set as current but forgot to 'Save'.[/font]

[font=verdana,geneva,sans-serif]Not sure about this stuff I need to add to the htaccess file.[/font]

[font=verdana,geneva,sans-serif]Does “[color=#660066]AddHandler[/color][color=#000000] application[/color][color=#666600]/[/color][color=#000000]x[/color][color=#666600]-[/color][color=#000000]httpd[/color][color=#666600]-[/color][color=#000000]php54 [/color][color=#666600].[/color][color=#000000]php [/color][color=#666600].[/color][color=#000000]php5 [/color][color=#666600].[/color][color=#000000]php4 [/color][color=#666600].[/color][color=#000000]php3” go anywhere[/color][/font]

[font=verdana,geneva,sans-serif][size=4][color=#000000]in the file as long as it is on a line of it's own ?[/color][/size][/font]

Put it on the first line.

Thank you.