Change category for some products results in Ooops! error

I have an issue with a few of the products in my store. If I try to change the Category only and click Save I get the plain white “Ooops! An error has occurred” screen. However, if I change something else in addition - change the Category and slightly modify the product name - it saves just fine and changes the Category. I get the same error if I make NO changes to the item and click Save.



This only happens with a few items, coincidentally they were all created by .csv import into the same category - but there are other items created in the same import and same category that don't have this issue. I can't find any difference in how these items are configured, or any difference in how the categories I'm moving from and to are configured.



I tried cloning one of the items that has this issue, but the cloned item also behaves the same way. I use Chrome, tried FF and IE and the same thing happened.



I know it's a bit of a shot in the dark here - but anyone have any suggestions? I'm using CS-Cart 4.0.1. Thanks!