Can't Use Theme Editor - Get An Error

When I click on Theme Editor in Design - Themes, it opens the new page but the side panel where the editing is done doesn't show and this error pops up:

ErrorOops, something went wrong (Internal Server Error). Please try again.

I did delete var/cache and same result.

What do you see in the server error logs?

Where do I find those?

Where do I find those?

You can ask hosting administrator to provide you with the error logs

My hosting support seems to be useless. Would these be php error logs?

Ok I got him to be a little more helpful. He says the php error logs are the only error logs and that there aren't any errors to report.

After talking with someone else from my hosting provider's support team, I got this:

I have taken a look at your site and I was able to find your error log. You do have error logging turned on, and it is putting your PHP errors into this file:

"/home/username/public_html/error_log", inside that file there are many lines of the same message "[26-Sep-2016 14:51:26 UTC] PHP Warning: PHP Startup: Unable to load dynamic library '/' - / cannot open shared object file: No such file or directory in Unknown on line 0". This means that there is a file "" that is missing, and this is causing your problem with your cart.

Looks like htscanner extension is not installed on your server. Ask hosting administrator to install it

Ok after having them fix the htscanner issue (which they said was installed but I still had the same issue), they looked into it again and said:

This theme page is throwing the error:

[27-Sep-2016 15:05:51 America/Denver] PHP Fatal error: Uncaught --> Smarty: Unable to load template tygh 'common/colorpicker.tpl' in 'views/theme_editor/view.tpl' <--

thrown in /home/username/public_html/storedirectory/app/lib/vendor/smarty/smarty/libs/sysplugins/smarty_internal_templatebase.php on line 129

Please provide this to your developer, and I am positive that they can resolve this problem, as it's an error in the code in this file.


Make sure the file exists and has correct permissions.


Make sure the file exists and has correct permissions.

It does exist and the file permissions are 0644 (same as all of the other files in the directory). The content in the file are:

Should be okay then.

The ErrorOops message generally means an issue with the database so the error messages concerning files doesn't make sense.

Do you have logging enabled in admin? If so, are there any database related errors showing?

I do have it enabled and it's generating reports but I can't tell if they're database-related. Here's the two that keep appearing (the blank lines are where I deleted what I think are sensitive info, i.e. license key, etc):

Requests (http/https request)
Request: 'dispatch=product_updates.check_available&request=%3C%3Fxml+version%3D%221.0%22+encoding%3D%22UTF-8%22%3F%3E%3CRequest+action%3D%22check_license%22+api%3D%223%22%3E%3Ctoken%3E3018111338%3C%2Ftoken%3E%3Cstore_key%____________%3B________________%3C%2Fstore_key%3E%3Cdomains%3E________________%3C%2Fdomains%3E%3Clicense_number%______________________________%3C%2Flicense_number%3E%3Cver%3E4.3.9%3C%2Fver%3E%3Cproduct_status%3E%3C%2Fproduct_status%3E%3Cproduct_build%3E%3C%2Fproduct_build%3E%3Cedition%3EULTIMATE%3C%2Fedition%3E%3Clang%3EEN%3C%2Flang%3E%3Cstore_uri%3Ehttp%3A%2F%2F________________%2F%3C%2Fstore_uri%3E%3Csecure_store_uri%3Ehttps%3A%2F%2F________________%2F%3C%2Fsecure_store_uri%3E%3Chttps_enabled%3EY%3C%2Fhttps_enabled%3E%3Cadmin_uri%3Ehttp%3A%2F%2F________________%2F%3C%2Fadmin_uri%3E%3Cstore_ip%3E174.29.220.182%3C%2Fstore_ip%3E%3C%2FRequest%3E'
Response: ACTIVE

Requests (http/https request)
Request: 'data=B7NQlQHPZ%2FsLSa9v5VqpN0fBFWEZ15meGLTkVf46q7R9fXmHyVjRQ1HS1bKSVJOZpO0SKp10n52%2BOlVyWxIZFxA4v90gpsrgUclK3ist59LNRBdbwdDmjRzChzfzhRDPcPKfS6SUijq5BIx8n6R%2BeSbwbTyMcmqBGqv0gCQMD068vFIyq0vyO%2FSVWdEK3wki8ut%2Fzg8OHEOzWts0YO0QBIeMcxoySXRdmt8y6OKF6IDnP2oMM8VJRZPMCo6kHvptU5Kr6px422E6Ff9KSPr1klC6MSR98pamq4WCakKszjKidyr2GqrJdhWlZE6dsEVB3BfBjz3xKdz3obFQUochOxjJKEfw99kl3Vrrd9kjms%2FQFYvSbiY8utzkRGenG0d1OaiMjOyq3%2FxObxjuqLIYccAd0h90LBrD%2BKX0iwnAl9o7tJPrBH92gsw1gSjT3gnGwjVoFLLIcXf0nfhHQJFseYC0jQ80CXSArlWqCbQ%2BwvWVQkQck81TanxUJ7y%2Fv2hCQM0McMl3IHg2oU5u2tkbegWYm2CS7mXEBm5cqObkvz6xwkyDJewi9N15%2BDDfmEOMJ7KhxQaTSJFIEAY1ESPEmJAvrrwWWemGXFVA1jCegINn7%2B7EzPm89oLJwZCJWWSjguTJWpckw70riOIqLfDRt7ZROGyFwxsTqb7kB2WHAkI%3D&action=subscriptions.notifications&access_id=ATYE8U'
Response: Mnuc24ZDG1rXsilXlXTqKlqJKTHJwYw680C6+mhypZmuC1c8J4dQeE037+skteHibm7oPtgbuHC2OFUWF+9lh/VsaXVtxodp1SJI2y9rVLAHpWyAQdUi3R5Mb5tPZaNbTJ/hSG/bGpgRNpNf1QQr9gPjSNonK3Qd4Y8dgavz5ngX+jDPDz6XKiBYmfiO4VcTQNISeNeLs1MrGRf4h9UB7RS4Ysv+psr4gs7bhc1xw9SVuwhAkfHgGlT3fTiEo73n3zoJR0XpB80xAu47HmF/ilAWwlfIz91I1PSKPd/US3W+Rqnman15fu3woipNGmiFo5e+fz06CH/egUfaioQO1hp2/sc1TG5sDFqRff2FwctggObpygckMAWIlc4ecQF+ml2f+gAVkAiObg33auk9ZWCTk5BVCqS/Gb8U5VsmPY3vX4WSny6MP3UgVkU3+SV+ed1xuhRbEGmnRPfoFrk2iV7vCvHZIsf1meAB9YkSWv4quvYME8AgGt0MY0uVK1hwcvQKTogJS9mtwkk2Dj7juVi5+n6XYh1qlCIgM5TVSCZT15pYam33ljUzSHr3jgSt0Am/jX/5mF9GV8h6yGaPdLSD+k0Fb6cYwlcv+dEHjF+iCMKo1QB90/UuofcxJffMSqK+33gO/2iKBilFYgy9Qny0a0jNhzrAgTN1V5UVr4tMwxSx0nOpuD5GYIInt45E0/EqYnNyod6W3MQp4RDVoCUUUwzxhNtpX/mnr20o+n5WPdDEZGwOuaxx3gquo8W5FiemPVcUgbCuhYZaZqYB5TbwzGKfNI+atcdFLsY8Tah9ALvb/lTxC73jC91eUXdYg7hiUIGYRX1q7BuP5MLkdgYkpARiaibxSUe3JAESfbQC8ziBbIVKcehv8NyfdRW6O8XHOiqvyayxeA6386ckb18Uvl+DUDLBTy2xoJgdX7nkbWIsOmloM2+c4yzjA6Xi+IyXSje3U042dxSIY3NFJweFfTehgScPWgaX6B6Su0KH+C2lxbNVh8YEBpu8Wsq1

Those are just requests. If there was a database error, it would say "database error".

Not sure what to tell you at this point. Someone is going to have to have a look.

I did an advanced search in the logs for database type and it didn't show any results (last one was over a month ago).

Should I post in BugTracker or contact support...?

Probably not a bug.

PM me FTP and I will have a look.

Just to update the conclusion on this topic: Much thanks to The Tool, it's been realized that the older, Basic themes are no longer available in CSC. So I switched to a responsive theme and am now able to use the Theme Editor.

Just to update the conclusion on this topic: Much thanks to The Tool, it's been realized that the older, Basic themes are no longer available in CSC. So I switched to a responsive theme and am now able to use the Theme Editor.

We fixed similar issue for one of our customers recently. The problem is caused by the reason that the theme editor tries to find colorpicker.tpl file from the store-front. But all theme editor files were moved to the backend templates in the latest versions. So we just copied the file from the backend template and it solved the issue. Hope this information will be useful for someone.

Just thought I'd chip in to confirm this, I've just had the same issue, copied colorpicker.tpl to the frontend here:


And the customiser is working fine again