Can't Upgrade 4.17.2.SP3 to 4.18.1

Hello community! Wondering if anyone else is having upgrade issues. So far I haven’t had much troubles with all of my prior updates up until now. My upgrade progress bar keeps stalling at Copy Files: app

Before starting, I turned my store off, disabled the couple of 3rd party add-ons that I have, cleared the cache, optimized my database, made a backup copy of my store files plus a backup of the database “just in case”, etc. Ran the “Check PHP Script Timeout” before starting to make sure that was all good (it passed). All the validators executed fine, it did a database backup, then the progress bar just sits at Copy Files: app The timer spins for a few minutes and then just disappears with the progress bar just doing nothing. I’m stumped and any help would be appreciated. Thanks!

Some of my PHP Settings:
PHP Version 8.0.30
max_execution_time: 3600
max_input_time: -1
memory_limit: 256M
cURL: enabled
cache_backend changed to ‘apcu’ in my config.local.php

Check the file /var/upgrade/core_log.txt for errors.

@CS-Cart_team, @thetool I checked the core_log.txt file as mentioned. I looked back at my past upgrades that succeeded to compare with this and what I noticed is:

#1: The log doesn’t continue after the entry “backup via mysqldump is disabled by config” After that it should’ve created an upg_core_4.7.2.SP3-4.18.1_datestamp entry backup file in the /var/backups/ directory but doesn’t, which of course doesn’t send me an upgrade information e-mail or any further steps.

#2: Prior major upgrades (4.15.2 to 4.16.1) and (4.16.2.SP1 to 4.17.1) had the following entries of “Found 1 validators at package” and then Executing “PHP Version” validator.

This major upgrade (4.17.2.SP3 to 4.18.1) had Found 0 validators at package. The line Executing “PHP Version” validator was missing.

#3: The line "Executing pre-upgrade script “/…/var/upgrade/packages/core/content/scripts/pre_script.php” is missing, but the next line “Pre-upgrade script executed successfully” was there.


If your email is working then the only thing I can suggest is looking at server error logs.

That’s just it though, it doesn’t get to the point to send me the e-mail. During the upgrade process it hangs before creating the zipped backup file. The next step after the backup file creation should be to send me an e-mail, but because the .zip file creation doesn’t happen, the e-mail doesn’t get sent out. Prior to those steps, it doesn’t run the Executing “PHP Version” validator because it shows “Found 0 validators at package”.

I’m just wondering if the upgrade script is supposed to find and run the “PHP Version” validator for this major upgrade the same way it ran for the previous major upgrades? Hoping @CS-Cart_team member could weigh in on this as well. Otherwise, I’ll just keep trying different things to see if I can get it to work. Thanks!

4.18.1 isn’t available to me yet so I can’t test it. I would think that others would post if they were having similar issues upgrading.?

try to select PHP 8.1 or 8.2

I doubt that newer versions of PHP is the issue. Their demos still run on PHP Version 7.4.

So CS-Cart works with PHP 8.1 but going to PHP 8.2 breaks it…Changing to 8.2 will give you this error:

“CS-Cart supports PHP from 7.2.5 and up to (but not including) 8.2.0 . Your current PHP version is 8.2.15 , please ask your host to change it.”

I went back to PHP 8.1, tried the upgrade and it still does the same thing and hangs. I’ve tried on both Edge and Chrome.

have you select all this php commands options in php 8.1 like the requirement page?

Hi @webtrader,

Thank you for the suggestion…Yes, I made sure to go over all the PHP Extensions to make sure they were enabled when I switched over to 8.1 before trying the upgrade process again.