Blank white page

So now I edited the social links, removing the “s” from https, because when clicking on the links to test, nothing happened. No page change, no error, nothing. Now after I removed the “s” and saved, my site goes to a blank white page. The page title is replaced with the page url.



Someone PLEASE help! I think I made a mistake changing to 4.0.2 because there is NO documentation, support is backlogged by days, and it appears folks here in the forum don't know much about it either.



ANYONE??? PLEASE??? I can't proceed now! I'm at a frikin standstill because I changed a damn font and a changed a link. really??? Edits like these should NOT cause such problems!!!

Does anyone know? I really can't proceed right now until I resolve this.



It's not mod_sec as that's disabled for now.

It's not my permissions as I just double checked and they're all set to cs-cart's recommendations.



My store is closed and it goes to my closed store page fine, but when I try to access via my store access key I get the blank white page with the page url in the title bar. Source is also blank.

I also had all blank white pages on the storefront today. The backend worked fine. Sent a ticket to CS-Cart and guess what - No answer.



I finally found whats wrong. In the: Design/Themes/Default Layout there was a new layout called “PS” that i didnt place there. I couldnt delete it from the backend, so i deleted it from PHPmyAdmin and set “Main” as the default, and then it worked again.



Not sure if this is the error on your site, but it was on my fresh 4.0.2-site. There also is another topic in the forum regarding white pages.

Hi Onkel_Sid, thanks for the response!

Unfortunately I must be having a different issue. In my Design/Themes/Default Layout it’s already set to Main (no new layout added). I also tried the suggestion in the link you provided (unchecking redirect in Stores > Regions) but having the same results.

Thank you for responding! Maybe someone down the road with a similar issue will benefit from it. :)

Still nothing from support on this. And now I can't get to my “Store Closed” page - before it at least went to that but now that just goes to a blank white page as well.

Could it be something in my .htaccess files?



This is what's in my public_html/ .htaccess (I have no idea why the IP deny are in there - looking those up, they appear to be in Amsterdam. I didn't add them):


deny from 95.211.238.109
deny from 95.211.238.110
SuPHP_ConfigPath /home/username/public_html

order allow,deny
allow from all





And this is what's in my .htaccess in my cs-cart store folder:

```php

DirectoryIndex index.html index.php





AddEncoding gzip .gz

RewriteCond %{REQUEST_FILENAME} .(js|css)$

RewriteCond %{HTTP:Accept-encoding} gzip

RewriteCond %{REQUEST_FILENAME}.gz -f

RewriteRule ^(.)$ $1.gz [QSA,L]



.css.gz$>

ForceType text/css

Header set Content-Encoding: gzip

Header set Cache-control: private



.js.gz$>

ForceType text/javascript

Header set Content-Encoding: gzip

Header set Cache-control: private





Header set Access-Control-Allow-Origin "
"







RewriteEngine on

Please note that RewriteBase setting is obsolete use it only in case you experience some problems with SEO addon.

Some hostings require RewriteBase to be uncommented

Example:

Your store url is http://www.yourcompany.com/store/cart

So “RewriteBase” should be:

RewriteBase /store/cart

RewriteBase /

Options -MultiViews

RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

RewriteRule api/(.)$ api.php?_d=$1&ajax_custom=1 [L,QSA]

RewriteCond %{REQUEST_URI} .(png|gif|ico|swf|jpe?g|js|css|ttf|svg|eot|woff)$ [or]

RewriteCond %{REQUEST_URI} store_closed.html$

RewriteCond %{REQUEST_FILENAME} !-f

RewriteCond %{REQUEST_FILENAME} !-d

RewriteRule ^(.
?)/(.*)$ $2 [L]

RewriteCond %{REQUEST_FILENAME} !-f

RewriteCond %{REQUEST_FILENAME} !-d

RewriteRule . index.php [L,QSA]



```

This is getting ridiculous all this waiting for help. Now when I try to access one of my content pages directly by typing the URL in the browser, I get an Error 404 - Not Found. I can't believe they don't care that a customer's store is DOWN for DAYS and losing money!

Dont you have a backup of your working store to go back to for now? Please tell us you did a backup before upgrading?

No, this is part of the reason I'm starting from scratch. My hosting company made an error that deleted my entire cart directory, and their routine backup was done after, so my store is gone. So since I had to rebuild from scratch, I decided to do it with the latest version of 4.0.2. I am almost done but just have these last 2 issues to resolve (white screen, & can't ad anymore variants to an option).



I could possibly open the store with partial options for my customers but I can't do anything at all until this white screen issue is solved. Therefore, I am at a complete standstill with my store until I get help from this forum or cs-cart support.

Hi Brennie369

I have the blank pages problem too (only on the product detail pages). Technical support at cs-cart suggested I increase the Master value of the max_execution_time up to 3600 (which is what the “Local Value” is set to). I was glad to get such a quick response from cs-cart but I don't have a clue how to change these settings.

However, cs-cart increased the memory_limit Local value on our server from 48M to 512M (they had FTP access) which seems to have solved the blank page problem for now.

Hopefully this will help you with your issue, if so maybe you could explain the jargon to me? I guess increasing the Master value will improve performance and prevent this happening again??

Thanks

Hi Sox,



Thank you for the reply and for sharing your fix! That’s what keeps this forum going. :)



The max_execution_time and memory_limit values exist in the php.ini document that is in your public_html root folder. My max_execution_time is currently set at 30 and my my memory_limit is at 1024.



What they’ve told me before about local and master values is this:

<br />
The Master value is a global configuration of your server which cannot be overwritten by the Local value, which can be set up locally in php.ini files.<br />

```<br />
And that the master values need to be changed by your server provider (hosting company). The local value we can change in the php.ini doc.<br />
<br />
EDIT: I just tried changing my max_execution_time to 3600 to match yours but it did not solve either of my two biggest current issues. Will post an update if I ever hear get it resolved by support.

(CS-Cart MultiVendor 4.01 on Windows Server) I had the same problem and now it is fixed. Here's what I found and corrected. HTML was not properly displaying on this website, but it was displaying on another one of my sites on the same server. I went into IIS Handler Mappings and looked at how Static Files for *.html were being handled in cs-cart and compared that to the wther site that DID properly display html. Found that the other site was using FastCGI for handling Static Files for *.html. So I changed the cscart site handling to be the same as the non-cscart site and now it displays properly.

Update again:

I added: max_input_vars = 3000 to my php.ini file (per my hosting providers support - they said it doesn't exist in there by default and needs to be added) and it did not solve any of my current issues. They also told me that adding this to the (local) php.ini file DOES override the master value.



Just an FYI for everyone.

[quote name='Markman1' timestamp='1381930876' post='169855']

(CS-Cart MultiVendor 4.01) I had the same problem and now it is fixed. Here's what I found and corrected. HTML was not properly displaying on this website, but it was displaying on another one of my sites on the same server. I went into IIS Handler Mappings and looked at how Static Files for *.html were being handled in cs-cart and compared that to the wther site that DID properly display html. Found that the other site was using FastCGI for handling Static Files for *.html. So I changed the cscart site handling to be the same as the non-cscart site and now it displays properly.

[/quote]



Marman1, where do we go to check these settings?

On a windows server you go to Start → (on right) → Administrative tools → IIS Manager → Expand Sites - Click on [Your Site Name] and in the middle block, click on icon “Handler Mappings”.

I'm on a Linux server and don't see any options in my cPanel I don't see any options for IIS.

Sorry, IIS is a “Windows” thing, not Linux. Maybe others in the forum can help?

Ok getting a little closer. Support responded with:

[quote]We found out that the issue with the storefront was caused by the fact that your custom preset was created incorrectly. We had to remove the custompreset.less file from the design/themes/basic/presets/data directory of your CS-Cart installation to be able to open the storefront.[/quote]



This is fine and it solved the blank white page issue, but now my site stays on the store closed page even after un-checking the close store option and clearing cache.

Remove the access key.

That solved it! Thanks The Tool!