admin and index php blank also can't add to cart

Hello ladies and Gentlemen I hope that someone out there can help.



I have an install of my store that was working great for the past year then all of a sudden you can not get to the front end or the admin panel. They are blank pages. v2.0.7 I can use a product link and get to the store but you cannot add anything to the cart. when you click on add to cart It gives the error that your cart is empty and you cannot proceed to checkout. When you click on store home it goes back to a blank page. I have tried the php?cc and it will go to the main page then go back to the blank if you try to go anywhere else.



I contacted the hosting company and they did a test php page and it worked just fine.



Also as a test I installed a default store v2.0.7 in another directory with all of the defaults just to see if I could get it working. It did not work it also has the blank admin and index.php page. Again. I can get to the front end and admin if I enter the php?cc but will not go any further



I have searched all over this forum and on the internet to try to find a solution and didn’t find a definitive answer.



I have tried different permissions and some of the other suggestions on this site and others none worked. I have put them all back to the way they were and still nothing. And like a mentioned i tried it on the main store and the test store and they both do exactly the same thing .



I emailed the helpdesk also and have not received a response



Can anyone help?

What’s your URL?

this is the test store url



[url]http://www.sandgear.com/store/index.php[/url]

Does your root/index.php file have any content? What about your .htaccess file?

yes both have content



Index



/***************************************************************************
* *
* Copyright (c) 2009 Simbirsk Technologies Ltd. All rights reserved. *
* *
* This is commercial software, only users who have purchased a valid *
* license and accept to the terms of the License Agreement can install *
* and use this program. *
* *
****************************************************************************
* PLEASE READ THE FULL TEXT OF THE SOFTWARE LICENSE AGREEMENT IN THE *
* "copyright.txt" FILE PROVIDED WITH THIS DISTRIBUTION PACKAGE. *
****************************************************************************/


//
// $Id: index.php 7808 2009-08-12 14:28:04Z zeke $
//
define('AREA', 'C');
define('AREA_NAME' ,'customer');
require './prepare.php';
require './init.php';

define('INDEX_SCRIPT', Registry::get('config.customer_index'));

fn_dispatch();

?>


htaccess

DirectoryIndex index.html index.php


RewriteEngine on
# Some hostings require RewriteBase to be uncommented
# Example:
# Your store url is [url]http://www.yourcompany.com/store/cart[/url]
# So "RewriteBase" should be:
# RewriteBase /store/cart
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !\.(png|gif|ico|swf|jpe?g|js|css)$
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . index.php?sef_rewrite=1 [L,QSA]

RewriteCond %{REQUEST_FILENAME} .*\/catalog\/.*
RewriteCond %{REQUEST_FILENAME} -d
RewriteCond %{REQUEST_FILENAME}/index.html !-f
RewriteRule . index.php?sef_rewrite=1 [L,QSA]

2 more things to check.

  1. your php error_log
  2. your browser’s error_console (if using FF, or any errors if using IE).

Sorry I am not sure where to check the error_php



The browser shows no errors unless I am not looking in the correct place sorry

Also make sure your js-compression (config.local.php) is turned off in 2.1.2 since they didn’t test it before it was released. There are JS files that are missing statement terminators so they don’t compress properly.